maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Reynolds (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MASSEMBLY-256) Regression: pom properties are no longer expanded in descriptor.
Date Mon, 25 Feb 2008 16:16:29 GMT

    [ http://jira.codehaus.org/browse/MASSEMBLY-256?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_124987
] 

Mark Reynolds commented on MASSEMBLY-256:
-----------------------------------------

I pointed to your staging repo but I am still not having any luck. I don't think this is working.
Using my original example, I have tried <outputDirectory>${fileLocation}</outputDirectory>
and <outputDirectory>${project.properties.fileLocation}</outputDirectory> in the
descriptor. When I package with -X i see something like this:

[DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-assembly-plugin:2.2-beta-2:attached'
-->
[DEBUG]   (s) appendAssemblyId = true
[DEBUG]   (f) attach = true
[DEBUG]   (s) basedir = C:\Documents and Settings\mreynolds\Desktop\assembly-issue
[DEBUG]   (s) descriptors = [Ljava.lang.String;@154864a
[DEBUG]   (f) dryRun = false
[DEBUG]   (s) finalName = myartifact-1.0-SNAPSHOT
[DEBUG]   (f) ignoreDirFormatExtensions = false
[DEBUG]   (s) ignoreMissingDescriptor = false
[DEBUG]   (s) includeSite = false
[DEBUG]   (s) localRepository = [local] -> file://C:\Documents and Settings\mreynolds\.m2\repository
[DEBUG]   (s) outputDirectory = C:\Documents and Settings\mreynolds\Desktop\assembly-issue\target
[DEBUG]   (f) project = MavenProject: com.whatever:myartifact:1.0-SNAPSHOT @ C:\Documents
and Settings\mreynolds\Desktop\assembly-issue\pom.xml
[DEBUG]   (s) reactorProjects = [MavenProject: com.whatever:myartifact:1.0-SNAPSHOT @ C:\Documents
and Settings\mreynolds\Desktop\assembly-issue\pom.x
ml]
[DEBUG]   (f) remoteRepositories = [[mrb.stage] -> http://people.apache.org/~jdcasey/stage/maven-repository-builder/1.0-alpha-2,
[map.stage] -> http:/
/people.apache.org/~jdcasey/stage/maven-assembly-plugin/2.2-beta-2, [central] -> http://repo1.maven.org/maven2]
[DEBUG]   (s) siteDirectory = C:\Documents and Settings\mreynolds\Desktop\assembly-issue\target\site
[DEBUG]   (f) skipAssembly = false
[DEBUG]   (s) tarLongFileMode = warn
[DEBUG]   (s) tempRoot = C:\Documents and Settings\mreynolds\Desktop\assembly-issue\target\archive-tmp
[DEBUG]   (s) workDirectory = C:\Documents and Settings\mreynolds\Desktop\assembly-issue\target\assembly\work
[DEBUG] -- end configuration --
[INFO] [assembly:attached {execution: default}]
[INFO] Reading assembly descriptor: src/main/assembly/myassembly.xml
[DEBUG] Before assembly is interpolated:

<?xml version="1.0" encoding="UTF-8"?><assembly>
  <id>myassembly</id>
  <formats>
    <format>zip</format>
  </formats>
  <includeBaseDirectory>false</includeBaseDirectory>
  <fileSets>
    <fileSet>
      <directory>src/main/files</directory>
      <outputDirectory>${project.properties.fileLocation}</outputDirectory>
    </fileSet>
  </fileSets>
</assembly>


[DEBUG] After assembly is interpolated:

<?xml version="1.0" encoding="UTF-8"?><assembly>
  <id>myassembly</id>
  <formats>
    <format>zip</format>
  </formats>
  <includeBaseDirectory>false</includeBaseDirectory>
  <fileSets>
    <fileSet>
      <directory>src/main/files</directory>
      <outputDirectory>${project.properties.fileLocation}</outputDirectory>
    </fileSet>
  </fileSets>
</assembly>


[DEBUG] All known ContainerDescritporHandler components: [plexus]
[DEBUG] No dependency sets specified.
[DEBUG] FileSet[${project.properties.fileLocation}] dir perms: 40755 file perms: 100644
[DEBUG] The archive base directory is 'null'
[DEBUG] Adding file-set from directory: 'C:\Documents and Settings\mreynolds\Desktop\assembly-issue\src\main\files'
assembly output directory is: '${project.properties.fileLocation}/'
[DEBUG] Adding directory file-set in: C:\Documents and Settings\mreynolds\Desktop\assembly-issue\src\main\files
to archive location: ${project.propert
ies.fileLocation}/
[INFO] Building zip: C:\Documents and Settings\mreynolds\Desktop\assembly-issue\target\myartifact-1.0-SNAPSHOT-myassembly.zip
[DEBUG] adding directory ${project.properties.fileLocation}/
[DEBUG] adding entry ${project.properties.fileLocation}/some.file
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3 seconds
[INFO] Finished at: Mon Feb 25 11:12:44 EST 2008
[INFO] Final Memory: 7M/15M
[INFO] ------------------------------------------------------------------------

> Regression: pom properties are no longer expanded in descriptor.
> ----------------------------------------------------------------
>
>                 Key: MASSEMBLY-256
>                 URL: http://jira.codehaus.org/browse/MASSEMBLY-256
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2-beta-2
>         Environment: maven 2.0.8
> windows xp sp2
>            Reporter: Mark Reynolds
>            Assignee: John Casey
>             Fix For: 2.2-beta-2
>
>         Attachments: assembly-issue.zip
>
>
> Attached is a minimal project which demonstrates this issue.
> The pom contains a property:
>     <project>
>         ...
>         <properties>
>             <fileLocation>file/path</fileLocation>
>         </properties>
>     </project>
> The descriptor uses this property in specifying the output directory for a fileSet:
> <assembly>
>     ...
>     <fileSets>
>         <fileSet>
>             <directory>src/main/files</directory>
>             <outputDirectory>${fileLocation}</outputDirectory>
>         </fileSet>
>     </fileSets>
> </assembly>
> In versions 2.1, 2.2-beta-1, and 2.2-SNAPSHOT of the assembly plugin, this property is
expanded so the resulting archive has files in file/path/....
> In the latest 2.2-beta-2-SNAPSHOT, the resulting archive has files in ${fileLocation}/...

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message