maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MEAR-83) Documentation refers to jarModule instead of javaModule but jarModule doesn't seem to be released yet
Date Sat, 02 Feb 2008 16:20:57 GMT

    [ http://jira.codehaus.org/browse/MEAR-83?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_122135
] 

David Smiley commented on MEAR-83:
----------------------------------

What you say is fair... though this hurts my maven experience a bit.  The specific error I
got took me a long while to diagnose (which may be something that the ear plugin could improve
any way).  How would I know to even check the plugin version?  Even the examples don't specify
a version number (which misled me to believe that I didn't have to either).  Perhaps all plugin
pages (maven-wide, not just ear) should declare prominently at a banner on the top the plugin
info including the version that the documentation applies to.  I dunno.

> Documentation refers to jarModule instead of javaModule but jarModule doesn't seem to
be released yet
> -----------------------------------------------------------------------------------------------------
>
>                 Key: MEAR-83
>                 URL: http://jira.codehaus.org/browse/MEAR-83
>             Project: Maven 2.x Ear Plugin
>          Issue Type: Bug
>    Affects Versions: 2.1
>         Environment: Maven version: 2.0.8
> Java version: 1.5.0_13
>            Reporter: David Smiley
>            Assignee: Stephane Nicoll
>
> The documentation up right now http://maven.apache.org/plugins/maven-ear-plugin/modules.html
 mentions that jarModule should be used instead of javaModule.  That may be so for the latest
released version of this plugin, but if I use the plugin without explicitly specifying the
version with maven 2.0.8, I don't get that version -- I get version 2.1.
> FYI, the error I got when attempted to use jarModule was bizarre.  ALL it told me (no
other info was helpful whatsoever) was the following error:
> java.lang.InstantiationException: org.apache.maven.plugin.ear.EarModule

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message