maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Sellers (JIRA)" <>
Subject [jira] Commented: (MECLIPSE-94) Allow eclipse:eclipse to work on pom (and other) projects
Date Sun, 03 Feb 2008 04:09:58 GMT


Jim Sellers commented on MECLIPSE-94:

Just to add another use case:

1) you check out the pom project and its nested modules (eclipse generates the parent .project
2) you run eclipse:eclipse to generate all needed files
3) you'd like to clean something up, so you call eclipse:clean
4) now eclipse doesn't recognize the project at all so you can't make any changes to the parent
pom since the .project files is gone

This has happened quite often where I work.  The work around is usually to comment out the
modules section, change the type from "pom" to "jar", call eclipse:eclipse, and then undo
the changes to the pom.xml file.  That's pretty annoying.

It would be great (as many have suggested) to just create a simple .project for projects of
type pom.

> Allow eclipse:eclipse to work on pom (and other) projects
> ---------------------------------------------------------
>                 Key: MECLIPSE-94
>                 URL:
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Improvement
>    Affects Versions: 2.1
>            Reporter: Felipe Leme
>         Attachments: MECLIPSE-94.patch
> I'm creating a Java EE project based on the m2book (which I was reviewing; it's not available
yet...) and one of the projects is a pom-packaging project used for integration tests. According
to Vincent, currently this project must be a pom (in fact, I tried to set it as jar, but then
the test phase would be run anyway, which would cause the tests to fail), as it doesn't produces
a jar. But as it has java files (on the src/main/it/java directory), I tried to call eclipse:eclipse
but it fails, saying that "Not running eclipse plugin goal for pom project".
> For these scenarios, I think a propery would be enough. At first I thought something
about a 'force' or 'forceGeneration' property, would enough, which the code change being from:
>  if ( "pom".equals( packaging ) && eclipseProjectDir == null ) 
> to:
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !forceGeneration
> Then I realized there is other place where the pom nature is checked:
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !forceGeneration
> So, I think a better name for the property would be 'javaProject' and the change would
> final boolean isJavaProjectProperty = // read property; defaults to false...
>  if (  "pom".equals( packaging ) && eclipseProjectDir == null && !isJavaProjectProperty
> isJavaProject = isJavaProjectProperty || !"ear".equals( packaging ) && !"pom".equals(
packaging );
> If nobody objects and someone is willing to apply the changes, I can provide such patch
(with the proper test cases).
> -- Felipe
> PS: I'm assigning it to Vincent for now, as he 'dreamed' that such features already existed

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message