maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "JR Boyens (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MENFORCER-36) In an POM inheritance situation the enforcer plugin does not correctly detect dependency versions
Date Wed, 13 Feb 2008 20:55:28 GMT
In an POM inheritance situation the enforcer plugin does not correctly detect dependency versions
-------------------------------------------------------------------------------------------------

                 Key: MENFORCER-36
                 URL: http://jira.codehaus.org/browse/MENFORCER-36
             Project: Maven 2.x Enforcer Plugin
          Issue Type: Bug
          Components: Rule API
            Reporter: JR Boyens
            Assignee: Brian Fox


With plugin dependency versions specified in the parent in a <properties> element and
utilized in a <build><plugins> element children POM fail the requirePluginVersions
rule with the message that their dependencies are not valid.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message