maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Gier (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MNG-3561) Improved error message when maven 2.1 is run with jdk 14
Date Thu, 01 May 2008 15:20:46 GMT
Improved error message when maven 2.1 is run with jdk 14
--------------------------------------------------------

                 Key: MNG-3561
                 URL: http://jira.codehaus.org/browse/MNG-3561
             Project: Maven 2
          Issue Type: Improvement
          Components: Command Line
    Affects Versions: 2.1-alpha-1
         Environment: Maven 2.1-alpha-1-SNAPSHOT
            Reporter: Paul Gier
            Priority: Minor


Currently if I try to run maven 2.1-alpha-1-SNAPSHOT with java 1.4 I get the standard jvm
errors about wrong class type.  It would be nice to have some better error message saying
that java 1.5 or higher is required.  This could probably go into the startup script.

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/codehaus/plexus/logging/AbstractLogEnabled
(Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message