maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Fox (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-3550) Support more prerequisites like compiler version
Date Thu, 15 May 2008 13:01:27 GMT

    [ http://jira.codehaus.org/browse/MNG-3550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=134941#action_134941
] 

Brian Fox commented on MNG-3550:
--------------------------------

The enforcer is definately the place to check for the other prerequisites

> Support more prerequisites like compiler version
> ------------------------------------------------
>
>                 Key: MNG-3550
>                 URL: http://jira.codehaus.org/browse/MNG-3550
>             Project: Maven 2
>          Issue Type: Improvement
>          Components: POM
>            Reporter: Vincent Siveton
>            Priority: Minor
>             Fix For: 2.1-alpha-1
>
>
> It should be useful if the <prerequisites/> tag could support more informations
than the maven version. I could imagine something like:
> {noformat}
> <project>
> ...
>   <prerequisites>
>     <maven>2.0.6</maven>
>     <compiler>1.5</compiler>
>     <memory>512m</memory>
>     <diskSpace>100m</diskSpace>
>   </prerequisites>
> ...
> </project>
> {noformat}
> See the concrete use case in the Maven Plugin Plugin report:
> http://maven.apache.org/plugins/maven-plugin-plugin/plugin-info.html

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message