maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (WAGON-74) WebDav component references non-existant jetty pom and fails to install into maven when building.
Date Wed, 14 May 2008 07:58:28 GMT

     [ http://jira.codehaus.org/browse/WAGON-74?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brett Porter updated WAGON-74:
------------------------------

    Fix Version/s: 1.0-beta-3

> WebDav component references non-existant jetty pom and fails to install into maven when
building.
> -------------------------------------------------------------------------------------------------
>
>                 Key: WAGON-74
>                 URL: http://jira.codehaus.org/browse/WAGON-74
>             Project: Maven Wagon
>          Issue Type: Bug
>          Components: wagon-webdav
>    Affects Versions: 1.0-beta-2
>         Environment: Maven 2.0.5
>            Reporter: Derek Clarkson
>            Priority: Blocker
>             Fix For: 1.0-beta-3
>
>
> When attempt to deploy using the webdav to a local Archiva repository I get the message:
> Protocol [dav] is unsupported by the current configuration.
> Turning on debug I see at the top of the log:
> [DEBUG] Artifact not found - using stub model: Unable to download the artifact from any
repository
>   org.mortbay.jetty:jetty:pom:4.2.12
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   aegeon-proxy (http://192.168.0.91:2222/proxy/aegeon)
> Looking inside the repo1.maven.org/maven2 repository I can see that the directory exists
for jetty 4.2.12 but there is no pom in it. My build pom  makes reference to the following
extension:
> 		<extensions>
> 			<extension>
> 				<groupId>org.apache.maven.wagon</groupId>
> 				<artifactId>wagon-webdav</artifactId>
> 				<version>1.0-beta-2</version>
> 			</extension>
> 		</extensions>
> Please suggest a fix as this is blocking our development because we cannot deploy to
our local Archiva server.
> ciao
> Derek

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message