maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MINVOKER-38) Support easy install of IT parent POM
Date Wed, 14 May 2008 21:42:27 GMT

    [ http://jira.codehaus.org/browse/MINVOKER-38?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=134864#action_134864
] 

Olivier Lamy commented on MINVOKER-38:
--------------------------------------

I'm curious to understand how you want to fix that ?
Because users can already have a parent pom for their its and we can break some builds with
changing this.
And no it's locked in maven himself (2.0.9). 

> Support easy install of IT parent POM
> -------------------------------------
>
>                 Key: MINVOKER-38
>                 URL: http://jira.codehaus.org/browse/MINVOKER-38
>             Project: Maven 2.x Invoker Plugin
>          Issue Type: New Feature
>    Affects Versions: 1.1
>            Reporter: Benjamin Bentmann
>            Priority: Minor
>
> Recently it popped into my mind that all IT POMs need to lockdown plugin versions as
well to make the tests reproducible. Doing this individually for each IT POM isn't that much
fun so one quickly dreams of a common parent POM with a {{<pluginManagement>}}.
> One could already install such an IT parent by means of two Invoker executions or the
help of the Install Plugin but that's far too much hassle to copy one little POM around.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message