maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abel Muiño (JIRA) <j...@codehaus.org>
Subject [jira] Commented: (MNG-3617) Different behavior Maven 2.0.9 / Maven 2.1 for plugins w/ scope = provided
Date Thu, 05 Jun 2008 19:33:53 GMT

    [ http://jira.codehaus.org/browse/MNG-3617?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=137549#action_137549
] 

Abel Muiño commented on MNG-3617:
---------------------------------

This has been verified with maven 2.1.x built from svn revision 655675 and also 659801.
Removing the plug-in dependency with "provided" scope makes it work on 2.1.x.

> Different behavior Maven 2.0.9 / Maven 2.1 for plugins w/ scope = provided
> --------------------------------------------------------------------------
>
>                 Key: MNG-3617
>                 URL: http://jira.codehaus.org/browse/MNG-3617
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Ant tasks, Inheritance and Interpolation
>    Affects Versions: 2.1
>         Environment: OSX and win32
>            Reporter: Nicolas Richeton
>         Attachments: ant-test.zip
>
>
> The attached sample project builds with maven 2.0.x and fails with maven 2.1. 
> The problem is that one plugin has a "provided" scope.
> See http://code.google.com/p/q4e/issues/detail?id=459

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message