maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (WAGON-209) Extend Wagon API to support the Stage Plugin
Date Sun, 01 Jun 2008 03:50:53 GMT

     [ http://jira.codehaus.org/browse/WAGON-209?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brett Porter closed WAGON-209.
------------------------------

         Assignee: Brett Porter
       Resolution: Not A Bug
    Fix Version/s:     (was: 1.0-beta-3)

wagon api 1.0-beta-2 already includes "CommandExecutor", the correct one to use.

> Extend Wagon API to support the Stage Plugin
> --------------------------------------------
>
>                 Key: WAGON-209
>                 URL: http://jira.codehaus.org/browse/WAGON-209
>             Project: Maven Wagon
>          Issue Type: New Feature
>          Components: wagon-provider-api
>    Affects Versions: 1.0-beta-2
>            Reporter: Benjamin Bentmann
>            Assignee: Brett Porter
>
> From the source of the [Maven Stage Plugin|http://maven.apache.org/plugins/maven-stage-plugin/]:
> {code:java}
> ( (ScpWagon) targetWagon ).executeCommand( command );
> {code}
> This smells: The plugin is downcasting to an implementation class, happily breaking the
interface design and making the target wagon non-interchangeable.
> The atomic Wagon operations required by the plugin should be identified and added to
the Wagon API. Wagons that can't support these new operations could simply implement the methods
by throwing an {{UnsupportedOperationException}} exception.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message