maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Billemont (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MECLIPSE-492) Maven Eclipse Plugin does not take dependencyManagement excludes into account when building eclipse CP configuration.
Date Fri, 19 Sep 2008 15:31:49 GMT
Maven Eclipse Plugin does not take dependencyManagement excludes into account when building
eclipse CP configuration.
---------------------------------------------------------------------------------------------------------------------

                 Key: MECLIPSE-492
                 URL: http://jira.codehaus.org/browse/MECLIPSE-492
             Project: Maven 2.x Eclipse Plugin
          Issue Type: Bug
          Components: Core : Dependencies resolution and build path
    Affects Versions: 2.5.1
            Reporter: Maarten Billemont


I have a parent pom that excludes xml-apis:xml-apis from dom4j:dom4j in the dependencyManagement
section.  To make certain that as the project development progresses no artifacts depend on
xml-apis:xml-apis (it is superseded by org.apache.xerces:xml-apis) I've forced the version
of xml-apis:xml-apis in the same dependencyManagement section to be -1.  No artifact should
depend on it since I'm excluding all dependencies on it manually and adding org.apache.xerces:xml-apis
as a manual dependency.  In Maven this works fine.  When I run maven-eclipse-plugin in a child
module of this pom artifact which depends on dom4j:dom4j however, it tries to download xml-apis:xml-apis:jar:-1
and after failing it adds it to the project's classpath configuration (which obviously causes
eclipse to throw errors not being able to find xml-apis:xml-apis:jar:-1 in my local repository.

<dependencyManagement>
    <dependencies>
        <dependency>
            <groupId>dom4j</groupId>
            <artifactId>dom4j</artifactId>
            <version>${dom4j.version}</version>

            <excludes>
                <exclude>
                    <groupId>xml-apis</groupId>
                    <artifactId>xml-apis</artifactId>
                </exclude>
            </excludes>
        </dependency>

        <dependency>
            <groupId>xml-apis</groupId>
            <artifactId>xml-apis</artifactId>
            <version>-1</version>
        </dependency>
    </dependencies>
</dependencyManagement>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message