maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MRESOURCES-8) maven-resources-plugin ignores configuration/resources property (add a new mojo to copy resources)
Date Fri, 12 Sep 2008 21:37:49 GMT

    [ http://jira.codehaus.org/browse/MRESOURCES-8?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=147837#action_147837
] 

Olivier Lamy commented on MRESOURCES-8:
---------------------------------------

Implemented in rev 694813
I leave the issue open until there is more tests and documentation.

> maven-resources-plugin ignores configuration/resources property (add a new mojo to copy
resources)
> --------------------------------------------------------------------------------------------------
>
>                 Key: MRESOURCES-8
>                 URL: http://jira.codehaus.org/browse/MRESOURCES-8
>             Project: Maven 2.x Resources Plugin
>          Issue Type: New Feature
>    Affects Versions: 2.1, 2.2
>            Reporter: Leszek Gawron
>            Assignee: Olivier Lamy
>             Fix For: 2.3
>
>         Attachments: example.zip, MRESOURCES-8-workaround.patch, pom.xml
>
>
> I am evaluating maven + eclipse combo. In a trivial POM filtered resources exist only
in target/classes. If one executes Project -> Clean under eclipse this information is lost.
If filtered resources would appear as source folder they would survive cleaning and not got
overriden by unfiltered ones.
> I have been trying to implement a scenario which would allow filtered resources to appear
as "static" source folder under eclipse.
> The POM explains it best:
> {code:xml}
> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
>   <modelVersion>4.0.0</modelVersion>
>   <groupId>com.mobilebox.squash.client</groupId>
>   <artifactId>squash-client</artifactId>
>   <packaging>jar</packaging>
>   <version>1.0-SNAPSHOT</version>
>   <name>Maven Quick Start Archetype</name>
>   <url>http://maven.apache.org</url>
>   <build>
>     <plugins>
>       <plugin>
>         <artifactId>maven-resources-plugin</artifactId>
>         <executions>
>           <execution>
>             <id>prefilter-resources</id>
>             <phase>generate-resources</phase>
>             <goals>
>               <goal>resources</goal>
>             </goals>
>             <configuration>
>               <outputDirectory>target/generated-resources</outputDirectory>
>               <resources>
>                 <resource>
>                   <directory>src/main/resource-templates</directory>
>                   <filtering>true</filtering>
>                 </resource>
>               </resources>
>             </configuration>
>           </execution>
>         </executions>
>       </plugin>
>     </plugins>
>     <filters>
>       <filter>${ffile}</filter>
>     </filters>
>     <resources>
>       <resource>
>         <directory>src/main/resources</directory>
>       </resource>
>       <resource>
>         <directory>target/generated-resources</directory>
>       </resource>
>     </resources>
>   </build>
>   <dependencies>
>     <dependency>
>       <groupId>junit</groupId>
>       <artifactId>junit</artifactId>
>       <version>3.8.1</version>
>       <scope>test</scope>
>     </dependency>
>   </dependencies>
>   <properties>
>     <ffile>filter.properties</ffile>
>   </properties>
> </project>
> {code}
> thing is this part:
> {code:xml}
> <resources>
>   <resource>
>     <directory>src/main/properties</directory>
>     <filtering>true</filtering>
>   </resource>
> </resources>
> {code}
> is completely ignored. Instead for both maven-resource-plugin executions (the one in
generate-resources phase and the default one) this config is used:
> {code:xml}
> <resources>
>   <resource>
>     <directory>src/main/resources</directory>
>   </resource>
>   <resource>
>     <directory>target/generated-resources</directory>
>   </resource>
> </resources>
> {code}
> which of course breaks the whole idea.
> Is this a bug or a design decision. In latter case is there any equivalent approach I
might take?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message