maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Johns (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (SCM-406) scm tag does not work with Subversion 1.5.1
Date Thu, 11 Sep 2008 17:53:48 GMT

    [ http://jira.codehaus.org/browse/SCM-406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=147686#action_147686
] 

Michael Johns commented on SCM-406:
-----------------------------------

I have a little color I can add to this discussion.  We too use Maven, but I'm 99% sure this
has nothing to do with it.  Here's what I've done:

# Ran a release in Maven; failed with the error everyone else is seeing (svn: File '...' already
exists) 2. In a command prompt on our build box, changed to the project's working directory
that was created by the Maven build.  From there, ran a "svn --non-interactive copy -m <message>
. <test destination>" manually (same command that Maven runs, save for an explicit message
rather than --file).  Got the same error.
# Queried the working copy to see if any files were changed.  No files were changed, but about
10 new files were present (relics from the aborted build).
# Deleted the new files and ran the command again.  Failed again with same error.
# Ran an update on my working copy.  No changes happened (no new files, deleted files, or
changed files), but something happened because...
# Ran the command again, and it worked.

Some things to note:

* We have a multi-module project.
* We're on Windows Server 2003.
* I installed SVN using various methods (msi, unzip), and they all fail.  We have 1.5.2 with
the Apache 2.0 bindings.
* This problem doesn't happen with SVN 1.5.0, but it does happen with 1.5.1.

To me, this most definitely appears to be a SVN bug.  I've also posted this to the subversion
users mailing list since it's really more relevant to them.  But I figured I'd cross-post
it here to help exonerate Maven as the culprit.

> scm tag does not work with Subversion 1.5.1
> -------------------------------------------
>
>                 Key: SCM-406
>                 URL: http://jira.codehaus.org/browse/SCM-406
>             Project: Maven SCM
>          Issue Type: Bug
>          Components: maven-scm-provider-svn
>    Affects Versions: 1.0
>            Reporter: James William Dumay
>             Fix For: 1.1.1
>
>
> scm:checkin does not work with Subversion 1.5.1
> On release:perform (which I assume calls scm:checkin) the following error occurs:
> {code}
> svn: File '/svn/private/atlassian/confluence/tags/confluence-project-2.10-m1/conf-acceptance-test/pom.xml'
already exists
> {code}
> Using subversion 1.4.x is a good enough workaround.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message