maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lammert Westerhoff (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MNG-3815) maven-dependency-tree does not report conflicts between major versions
Date Mon, 03 Nov 2008 21:19:51 GMT

    [ http://jira.codehaus.org/browse/MNG-3815?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=152950#action_152950
] 

Lammert Westerhoff commented on MNG-3815:
-----------------------------------------

I just found out that commons-collections:commons-collections:jar:2.0:compile is not even
in the dependency tree at all!

And when I replace version 3.2.1 with 2.1 (e.g. 2.1 is now explicitly specified as nearest
dependency) is still is mentioning that 2.1 is omitted for 2.0. Even though 2.1 is actually
used according to the normal dependency report.

> maven-dependency-tree does not report conflicts between major versions
> ----------------------------------------------------------------------
>
>                 Key: MNG-3815
>                 URL: http://jira.codehaus.org/browse/MNG-3815
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Dependencies
>    Affects Versions: 2.0.9
>            Reporter: Lammert Westerhoff
>         Attachments: pom.xml
>
>
> When I run the maven-dependency-tree against my project, it reports the following:
> (commons-collections:commons-collections:jar:2.1:compile - omitted for conflict with
2.0)
> This is wrong, since I explicitly specified a dependency to commons-collections:commons-collections:jar:3.2.1:compile.
That means it should report that both 2.1 and 2.0 are omitted for conflict with 3.2.1. When
I check the normal dependencies report, I see that it included only the correct 3.2.1.
> The dependency tree:
> com.googlecode:maven-dependency-conflicts-plugin:maven-plugin:0.0.1-SNAPSHOT
>    org.apache.maven.plugins:maven-dependency-plugin:jar:2.0:compile
>       org.apache.maven:maven-artifact:jar:2.0.8:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>       (org.apache.maven:maven-plugin-api:jar:2.0.8:compile - omitted for conflict with
2.0.9)
>       org.apache.maven:maven-project:jar:2.0.8:compile
>          org.apache.maven:maven-settings:jar:2.0.8:compile
>             (org.apache.maven:maven-model:jar:2.0.8:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          org.apache.maven:maven-profile:jar:2.0.8:compile
>             (org.apache.maven:maven-model:jar:2.0.8:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          (org.apache.maven:maven-model:jar:2.0.8:compile - omitted for duplicate)
>          org.apache.maven:maven-artifact-manager:jar:2.0.8:compile
>             (org.apache.maven:maven-repository-metadata:jar:2.0.8:compile - omitted for
duplicate)
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>             (org.apache.maven:maven-artifact:jar:2.0.8:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:compile - omitted
for duplicate)
>          org.apache.maven:maven-plugin-registry:jar:2.0.8:compile
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>          (org.apache.maven:maven-artifact:jar:2.0.8:compile - omitted for duplicate)
>          (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>       org.apache.maven:maven-model:jar:2.0.8:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>       org.apache.maven:maven-core:jar:2.0.8:compile
>          (org.apache.maven:maven-settings:jar:2.0.8:compile - omitted for duplicate)
>          org.apache.maven.wagon:wagon-file:jar:1.0-beta-2:runtime
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>          org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.8:compile
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          org.apache.maven.wagon:wagon-http-lightweight:jar:1.0-beta-2:runtime
>             org.apache.maven.wagon:wagon-http-shared:jar:1.0-beta-2:runtime
>                jtidy:jtidy:jar:4aug2000r7-dev:runtime
>                (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>             (xml-apis:xml-apis:jar:1.0.b2:compile - scope updated from runtime; omitted
for duplicate)
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>          (org.apache.maven.reporting:maven-reporting-api:jar:2.0.8:compile - omitted
for conflict with 2.0.6)
>          (org.apache.maven:maven-profile:jar:2.0.8:compile - omitted for duplicate)
>          (org.apache.maven:maven-model:jar:2.0.8:compile - omitted for duplicate)
>          (org.apache.maven:maven-artifact:jar:2.0.8:compile - omitted for duplicate)
>          org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:compile
>             (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict
with 1.4.6)
>          (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          org.apache.maven:maven-repository-metadata:jar:2.0.8:compile
>             (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>          org.apache.maven:maven-error-diagnostics:jar:2.0.8:compile
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          (org.apache.maven:maven-project:jar:2.0.8:compile - omitted for duplicate)
>          commons-cli:commons-cli:jar:1.0:compile
>          (org.apache.maven:maven-plugin-api:jar:2.0.8:compile - omitted for duplicate)
>          org.apache.maven.wagon:wagon-ssh-external:jar:1.0-beta-2:runtime
>             (org.codehaus.plexus:plexus-utils:jar:1.0.4:runtime - omitted for conflict
with 1.4.6)
>             org.apache.maven.wagon:wagon-ssh-common:jar:1.0-beta-2:runtime
>                (org.codehaus.plexus:plexus-utils:jar:1.0.4:runtime - omitted for conflict
with 1.4.6)
>                (org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:runtime
- omitted for duplicate)
>                (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>          org.apache.maven:maven-plugin-descriptor:jar:2.0.8:compile
>             (org.apache.maven:maven-plugin-api:jar:2.0.8:compile - omitted for duplicate)
>             (org.apache.maven:maven-artifact:jar:2.0.8:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
- omitted for duplicate)
>          org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:compile
>             (classworlds:classworlds:jar:1.1-alpha-2:compile - omitted for duplicate)
>          (org.apache.maven:maven-artifact-manager:jar:2.0.8:compile - omitted for duplicate)
>          org.apache.maven:maven-monitor:jar:2.0.8:compile
>          org.apache.maven.wagon:wagon-ssh:jar:1.0-beta-2:runtime
>             com.jcraft:jsch:jar:0.1.27:runtime
>             (org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4:runtime - omitted
for duplicate)
>             (org.codehaus.plexus:plexus-utils:jar:1.0.4:runtime - omitted for conflict
with 1.4.6)
>             (org.apache.maven.wagon:wagon-ssh-common:jar:1.0-beta-2:runtime - omitted
for duplicate)
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-2:runtime - omitted
for duplicate)
>          (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>          classworlds:classworlds:jar:1.1:compile
>       org.codehaus.plexus:plexus-archiver:jar:1.0-alpha-9:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.1:compile - omitted for conflict with
1.4.6)
>          (org.codehaus.plexus:plexus-io:jar:1.0-alpha-1:compile - omitted for duplicate)
>       (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for conflict with
1.5.6)
>       org.apache.maven.shared:file-management:jar:1.1:compile
>          (org.apache.maven:maven-plugin-api:jar:2.0:compile - omitted for conflict with
2.0.8)
>          (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict with
1.4.6)
>          org.apache.maven.shared:maven-shared-io:jar:1.0:compile
>             (org.apache.maven:maven-artifact:jar:2.0.2:compile - omitted for conflict
with 2.0.8)
>             (org.apache.maven:maven-artifact-manager:jar:2.0.2:compile - omitted for
conflict with 2.0.8)
>             (org.apache.maven.wagon:wagon-provider-api:jar:1.0-alpha-6:compile - omitted
for conflict with 1.0-beta-2)
>             (org.codehaus.plexus:plexus-utils:jar:1.2:compile - omitted for conflict
with 1.4.6)
>          (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9:compile - omitted
for conflict with 1.0-alpha-9-stable-1)
>       org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
>          junit:junit:jar:3.8.1:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict with
1.4.6)
>          (classworlds:classworlds:jar:1.1-alpha-2:compile - omitted for conflict with
1.1)
>       org.apache.maven.shared:maven-dependency-analyzer:jar:1.0:compile
>          asm:asm:jar:3.0:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.6:compile - omitted for duplicate)
>          (org.apache.maven:maven-project:jar:2.0.5:compile - omitted for conflict with
2.0.8)
>          (org.apache.maven:maven-model:jar:2.0.5:compile - omitted for conflict with
2.0.8)
>          (org.apache.maven:maven-artifact:jar:2.0.5:compile - omitted for conflict with
2.0.8)
>       (org.apache.maven.shared:maven-dependency-tree:jar:1.1:compile - omitted for conflict
with 1.2)
>       org.apache.maven.shared:maven-common-artifact-filters:jar:1.0:compile
>          (org.apache.maven:maven-artifact:jar:2.0.8:compile - omitted for duplicate)
>          (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9:compile - omitted
for conflict with 1.0-alpha-9-stable-1)
>          org.apache.maven.shared:maven-plugin-testing-harness:jar:1.1:compile
>             (org.apache.maven:maven-project:jar:2.0:compile - omitted for conflict with
2.0.8)
>             (org.apache.maven:maven-core:jar:2.0:compile - omitted for conflict with
2.0.8)
>             (junit:junit:jar:3.8.1:compile - omitted for duplicate)
>             (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict
with 1.4.6)
>             (org.codehaus.plexus:plexus-archiver:jar:1.0-alpha-7:compile - omitted for
conflict with 1.0-alpha-9)
>       org.codehaus.plexus:plexus-io:jar:1.0-alpha-1:compile
>       org.apache.maven.reporting:maven-reporting-api:jar:2.0.6:compile
>          (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-7:compile - omitted for
conflict with 1.0-alpha-8)
>       (org.apache.maven.reporting:maven-reporting-impl:jar:2.0.4:compile - omitted for
duplicate)
>       org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-8:compile
>       (org.apache.maven.doxia:doxia-site-renderer:jar:1.0-alpha-8:compile - omitted for
conflict with 1.0-alpha-11)
>    org.apache.maven.shared:maven-dependency-tree:jar:1.2:compile
>       (org.apache.maven:maven-project:jar:2.0.8:compile - omitted for duplicate)
>    org.apache.maven:maven-plugin-api:jar:2.0.9:compile
>    org.apache.maven.reporting:maven-reporting-impl:jar:2.0.4:compile
>       (org.apache.maven:maven-project:jar:2.0.4:compile - omitted for conflict with 2.0.8)
>       commons-validator:commons-validator:jar:1.2.0:compile
>          commons-beanutils:commons-beanutils:jar:1.7.0:compile
>             (commons-logging:commons-logging:jar:1.0.3:compile - omitted for conflict
with 1.0.4)
>          commons-digester:commons-digester:jar:1.6:compile
>             (commons-beanutils:commons-beanutils:jar:1.6:compile - omitted for conflict
with 1.7.0)
>             (commons-logging:commons-logging:jar:1.0:compile - omitted for conflict with
1.0.3)
>             (commons-collections:commons-collections:jar:2.1:compile - omitted for conflict
with 2.0)
>             (xml-apis:xml-apis:jar:1.0.b2:compile - omitted for duplicate)
>          commons-logging:commons-logging:jar:1.0.4:compile
>          (oro:oro:jar:2.0.8:compile - omitted for conflict with 2.0.7)
>          xml-apis:xml-apis:jar:1.0.b2:compile
>       (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-7:compile - omitted for conflict
with 1.0-alpha-11)
>       (org.apache.maven:maven-plugin-api:jar:2.0.4:compile - omitted for conflict with
2.0.9)
>       oro:oro:jar:2.0.7:compile
>       (org.apache.maven.reporting:maven-reporting-api:jar:2.0.4:compile - omitted for
conflict with 2.0.6)
>       (org.apache.maven.doxia:doxia-site-renderer:jar:1.0-alpha-7:compile - omitted for
conflict with 1.0-alpha-8)
>    commons-collections:commons-collections:jar:3.2.1:compile
>    org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile
>       (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for conflict
with 1.0-alpha-8)
>       (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>       (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile - omitted
for conflict with 1.0-alpha-9-stable-1)
>    org.apache.maven.doxia:doxia-site-renderer:jar:1.0-alpha-11:compile
>       (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile - omitted for duplicate)
>       (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for conflict
with 1.0-alpha-8)
>       org.codehaus.plexus:plexus-i18n:jar:1.0-beta-7:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.1:compile - omitted for conflict with
1.4.6)
>       (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile - omitted
for conflict with 1.0-alpha-9-stable-1)
>       org.codehaus.plexus:plexus-velocity:jar:1.1.7:compile
>          (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-20:compile - omitted
for conflict with 1.0-alpha-9-stable-1)
>       org.apache.velocity:velocity:jar:1.5:compile
>          (commons-collections:commons-collections:jar:3.1:compile - omitted for conflict
with 3.2.1)
>          commons-lang:commons-lang:jar:2.1:compile
>          (oro:oro:jar:2.0.8:compile - omitted for conflict with 2.0.7)
>       org.apache.maven.doxia:doxia-decoration-model:jar:1.0-alpha-11:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>       (commons-collections:commons-collections:jar:3.2:compile - omitted for conflict
with 3.2.1)
>       org.apache.maven.doxia:doxia-module-apt:jar:1.0-alpha-11:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>          (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile - omitted for duplicate)
>          (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for
conflict with 1.0-alpha-8)
>       org.apache.maven.doxia:doxia-module-fml:jar:1.0-alpha-11:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>          (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile - omitted for duplicate)
>          (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for
conflict with 1.0-alpha-8)
>       org.apache.maven.doxia:doxia-module-xdoc:jar:1.0-alpha-11:compile
>          (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>          (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile - omitted for duplicate)
>          (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for
conflict with 1.0-alpha-8)
>       (org.apache.maven.doxia:doxia-module-xhtml:jar:1.0-alpha-11:compile - omitted for
duplicate)
>       (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>    org.apache.maven.doxia:doxia-module-xhtml:jar:1.0-alpha-11:compile
>       (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with
1.4.6)
>       (org.apache.maven.doxia:doxia-core:jar:1.0-alpha-11:compile - omitted for duplicate)
>       (org.apache.maven.doxia:doxia-sink-api:jar:1.0-alpha-11:compile - omitted for conflict
with 1.0-alpha-8)
>    org.codehaus.plexus:plexus-utils:jar:1.5.6:compile
> My dependencies:
> <dependencies>
>     <dependency>
>       <groupId>org.apache.maven.plugins</groupId>
>       <artifactId>maven-dependency-plugin</artifactId>
>       <version>2.0</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven.shared</groupId>
>       <artifactId>maven-dependency-tree
>       </artifactId>
>       <version>1.2</version>
>       <scope>compile</scope>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven</groupId>
>       <artifactId>maven-plugin-api</artifactId>
>       <version>2.0.9</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven.reporting</groupId>
>       <artifactId>maven-reporting-impl</artifactId>
>       <version>2.0.4</version>
>     </dependency>
>     <!-- Dependencies specified to resolve error conflicts -->
>     <dependency>
>       <groupId>commons-collections</groupId>
>       <artifactId>commons-collections</artifactId>
>       <version>2.1</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven.doxia</groupId>
>       <artifactId>doxia-core</artifactId>
>       <version>${doxiaVersion}</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven.doxia</groupId>
>       <artifactId>doxia-site-renderer</artifactId>
>       <version>${doxiaVersion}</version>
>     </dependency>
>     <dependency>
>       <groupId>org.apache.maven.doxia</groupId>
>       <artifactId>doxia-module-xhtml</artifactId>
>       <version>${doxiaVersion}</version>
>     </dependency>
>     <dependency>
>       <groupId>org.codehaus.plexus</groupId>
>       <artifactId>plexus-utils</artifactId>
>       <version>1.5.6</version>
>     </dependency>
>   </dependencies>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message