maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Gomes (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MDEPLOY-98) Cannot deploy-file to sftp using another username/password
Date Sun, 22 Mar 2009 22:46:13 GMT

    [ http://jira.codehaus.org/browse/MDEPLOY-98?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=170586#action_170586
] 

Richard Gomes commented on MDEPLOY-98:
--------------------------------------

You can see my pom.xml at
https://jquant.svn.sourceforge.net/svnroot/jquant/trunk/jquantlib/pom.xml

Near the beginning I explain that release managers and Continuum need to use Maven 2.1.0-M1
otherwise the deployiment does not work. Other developers dont need to deploy anything, so
they are OK with Maven 2.0.9.

Explaining these details to you I've got the solution:

I have a profile called 'manager' which requires Maven 2.1.0-M1 and defines the correct versions
for plugins, like this:

<profile>
	<id>[role=manager]</id>
	<activation>
		<property>
			<name>role</name>
			<value>manager</value>
		</property>
	</activation>
	<properties>
		<maven.required.version>2.1.0-M1</maven.required.version>
		<extension.wagon-ftp.version>1.0-beta-5-SNAPSHOT</extension.wagon-ftp.version>
		<extension.wagon-ssh.version>1.0-beta-4</extension.wagon-ssh.version>
		<extension.wagon-file.version>1.0-beta-4</extension.wagon-file.version>
		<extension.wagon-ftp.urlbase>ftp://ftp.jquantlib.org</extension.wagon-ftp.urlbase>
		<extension.wagon-ssh.urlbase>sftp://ftp.jquantlib.org/srv/users/continuum</extension.wagon-ssh.urlbase>
		<extension.wagon-file.urlbase>file://target</extension.wagon-file.urlbase>
	</properties>
</profile>


Then I tried again and requested the profile I need (-Drole=manager), like this:

mvn --update-plugins deploy:deploy-file -DpomFile=joda-primitives-0.6.pom -Durl=sftp://ftp.jquantlib.org/maven2/repos/external_free
-DrepositoryId=jquantlib-external_free -Dfile=lib/joda-primitives-0.6.jar -X -e > mvn-deploy.txt
-Drole=manager

but oddly it istill picking up the wrong version of the plugin. Please see attached file mvn-deploy-2.txt,
cos I'm not plenty sure.
I also tried to upgrade to 1.0-beta-5 but without any better result :(

Thanks

> Cannot deploy-file to sftp using another username/password
> ----------------------------------------------------------
>
>                 Key: MDEPLOY-98
>                 URL: http://jira.codehaus.org/browse/MDEPLOY-98
>             Project: Maven 2.x Deploy Plugin
>          Issue Type: Bug
>          Components: deploy:deploy-file
>    Affects Versions: 2.4
>         Environment: Java version: 1.6.0_12
> Java home: /data/JavaIDE/jdk1.6.0_12-x64/jre
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "linux" version: "2.6.26-1-amd64" arch: "amd64" Family: "unix"
>            Reporter: Richard Gomes
>         Attachments: mvn-deploy-2.txt, mvn-deploy.txt
>
>
> I'm trying to copy one artifact to my shared repository.
> I have the original .pom and .jar files downloaded locally from an external repository.
> My settings file has:
>     <server>
>       <id>jquantlib-external_free</id>
>       <username>continuum</username>
>       <password>secret</password>
>     </server>
> My pom.xml has:
> <repository>
>       <id>jquantlib-external_free</id>
>       <name>JQuantLib External Free Repository</name>
>       <url>sftp://ftp.jquantlib.org/maven2/repos/external_free</url>
>       <layout>default</layout>
>       <uniqueVersion>false</uniqueVersion>
>     </repository>
> These are the test cases and results:
> 1) initial trial according to documentation:
> mvn deploy:deploy-file -DpomFile=joda-primitives-0.6.pom -Durl=sftp://ftp.jquantlib.org/maven2/repos/external_free
-DrepositoryId=jquantlib-external_free -Dfile=lib/joda-primitives-0.6.jar -X -e
> It does ask not any authentication information but seems it's not picking up anything
from settings.xml, otherwise it would connect properly.
> 2) Trying to specify the username/password in the command line:
> mvn deploy:deploy-file -DpomFile=joda-primitives-0.6.pom -Durl=sftp://continuum:secret@ftp.jquantlib.org/maven2/repos/external_free
-DrepositoryId=jquantlib-external_free -Dfile=lib/joda-primitives-0.6.jar -X -e
> Authentication information is simply ignored.
> 3) Trying to removed 'repositoryId' 
> mvn deploy:deploy-file -DpomFile=joda-primitives-0.6.pom -Durl=sftp://continuum:secret@ftp.jquantlib.org/maven2/repos/external_free
 -Dfile=lib/joda-primitives-0.6.jar -X -e
> Authentication information is simply ignored.
> Asks my password (and not the password of account continuum):
> Password for rgomes@ftp.jquantlib.org:
> 4) back to the initial test and the stack trace
> mvn deploy:deploy-file -DpomFile=joda-primitives-0.6.pom -Durl=sftp://ftp.jquantlib.org/maven2/repos/external_free
-DrepositoryId=jquantlib-external_free -Dfile=lib/joda-primitives-0.6.jar -X -e  
> (logfile attached)
> Thanks a lot
> Richard Gomes

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message