maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Heritier (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MECLIPSE-546) Aspectj libraries are included if using the aspectj jars from the springsource bundle repository
Date Mon, 20 Apr 2009 22:33:44 GMT

     [ http://jira.codehaus.org/browse/MECLIPSE-546?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arnaud Heritier closed MECLIPSE-546.
------------------------------------

         Assignee: Arnaud Heritier
       Resolution: Fixed
    Fix Version/s: 2.7

> Aspectj libraries are included if using the aspectj jars from the springsource bundle
repository
> ------------------------------------------------------------------------------------------------
>
>                 Key: MECLIPSE-546
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-546
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: AJDT support
>    Affects Versions: 2.6
>            Reporter: Eric Berry
>            Assignee: Arnaud Heritier
>             Fix For: 2.7
>
>
> The dependency name from the springsource bundle repository is 
> <dependency>
>   <groupId>org.aspectj</groupId>
>   <artifactId>com.springsource.org.aspectj.runtime</artifactId>
>   <version>1.6.3.RELEASE</version>
>  </dependency>
> so it fails the check in EclipseClasspathWriter on line 508.  The line
> if( (config.getAjdtVersion() != 0) && dep.getArtifactId().toLowerCase().startsWith(
"aspectj" ) )
> needs to be changed to 
> if( (config.getAjdtVersion() != 0) && dep.getArtifactId().toLowerCase().contains(
"aspectj" ) )

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message