maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksander Adamowski (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MSITE-399) In a multi-module project, site plugin tries to get current project's artifacts from local repository (which may not be installed yet) even if relative paths are correctly set
Date Tue, 07 Apr 2009 10:59:12 GMT
In a multi-module project, site plugin tries to get current project's artifacts from local
repository (which may not be installed yet) even if relative paths are correctly set
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

                 Key: MSITE-399
                 URL: http://jira.codehaus.org/browse/MSITE-399
             Project: Maven 2.x Site Plugin
          Issue Type: Bug
            Reporter: Aleksander Adamowski


As reported in MISTE-307 by distinct people:

http://jira.codehaus.org/browse/MSITE-307?focusedCommentId=138004&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_138004

http://jira.codehaus.org/browse/MSITE-307?focusedCommentId=138503&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_138503

The problem is that the site plugin tries to get artifacts of the current multi-module project
from the repository instead of using the configured inter-module relative paths, which may
lead to stale data being used (artifacts from the previous build) or even build errors (if
the artifact's didn't get installed yet).




-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message