maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Gier (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MANTRUN-107) ANT_HOME environment variable breaks version of ant used by plugin
Date Wed, 01 Jul 2009 20:19:05 GMT

    [ http://jira.codehaus.org/browse/MANTRUN-107?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=182174#action_182174
] 

Paul Gier commented on MANTRUN-107:
-----------------------------------

I was not able to reproduce this issue.  I'm using Linux (Fedora 10).  I have ANT_HOME set
to ant 1.6.5, but the ant.version always shows 1.7.1 for me.  Can you provide the POM you
are using for this?

> ANT_HOME environment variable breaks version of ant used by plugin
> ------------------------------------------------------------------
>
>                 Key: MANTRUN-107
>                 URL: http://jira.codehaus.org/browse/MANTRUN-107
>             Project: Maven 2.x Antrun Plugin
>          Issue Type: Bug
>    Affects Versions: 1.3
>         Environment: Test for windows xp
>            Reporter: Jérémy Soula
>
> I have a build.xml with features only ant 1.7.1
> {code:xml}
> <project default="copy">
>     <target name="copy">
> 		<echo>${ant.version}</echo>
>         <copy todir="c:/temp" >
> 			<path>
> 				<pathelement path="${classpath}" />
> 			</path>
> 		</copy>
>     </target>
> </project>
> {code}
> With a environment variable ANT_HOME set to an ant 1.6.5, the build print 1.6.5 and launch
an error ("copy doesn't accept 'path' nested element").
> If i remove this variable, the build print 1.7.1 and passed.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message