maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNG-4466) Plugin Metaversion Compatibility
Date Mon, 23 Nov 2009 23:14:55 GMT

     [ http://jira.codehaus.org/browse/MNG-4466?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benjamin Bentmann closed MNG-4466.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 3.0-alpha-6
         Assignee: Benjamin Bentmann

Strangely this somehow got back working since then it seems. Anyway, the statement stands,
those metaversions should not be used. Extended the model validator in [r883537|http://svn.apache.org/viewvc?view=revision&revision=883537]
to ban them.

> Plugin Metaversion Compatibility
> --------------------------------
>
>                 Key: MNG-4466
>                 URL: http://jira.codehaus.org/browse/MNG-4466
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Plugins and Lifecycle
>    Affects Versions: 3.0-alpha-4
>            Reporter: Fernando Ribeiro
>            Assignee: Benjamin Bentmann
>             Fix For: 3.0-alpha-6
>
>
> According to the compatibility notes at http://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html:
> "For the sake of reproducible builds, Maven 3.x no longer supports usage of [the RELEASE
and LATEST] metaversions in the POM."
> LATEST is working fine for me in alpha-4.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message