maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Fox (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MENFORCER-77) "Require Release Version" rule does not have documented parameter "onlyWhenRelease"
Date Sat, 28 Nov 2009 18:40:55 GMT

     [ http://jira.codehaus.org/browse/MENFORCER-77?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brian Fox closed MENFORCER-77.
------------------------------

    Resolution: Fixed

Removed it from the docs. The rule doesn't really make sense to run for snapshots anyway.

> "Require Release Version" rule does not have documented parameter "onlyWhenRelease"
> -----------------------------------------------------------------------------------
>
>                 Key: MENFORCER-77
>                 URL: http://jira.codehaus.org/browse/MENFORCER-77
>             Project: Maven 2.x Enforcer Plugin
>          Issue Type: Bug
>          Components: Standard Rules
>    Affects Versions: 1.0-beta-1
>            Reporter: Maik Ebert
>
> The documention for version 1.0-beta-1 (see currently http://maven.apache.org/enforcer/enforcer-rules/requireReleaseVersion.html)
shows the parameter "onlyWhenRelease" for the rule "Require Release Version", but this parameter
does not exist (see currently http://maven.apache.org/enforcer/enforcer-rules/apidocs/org/apache/maven/plugins/enforcer/RequireReleaseVersion.html).
> So the documentation should be corrected or the parameter implemented.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message