maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNG-4449) Local parent pom isn't used
Date Tue, 17 Nov 2009 11:18:55 GMT

     [ http://jira.codehaus.org/browse/MNG-4449?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benjamin Bentmann closed MNG-4449.
----------------------------------

    Resolution: Incomplete
      Assignee: Benjamin Bentmann

Could be related to MNG-4433 or caused by a bad {{<relativePath>}} in the child POMs,
impossible to tell from the little information.

We just released 3.0-alpha-4. I suggest you try this new version and if the problem persists,
feel free to re-open the issue with sufficient information to reproduce the issue.

> Local parent pom isn't used
> ---------------------------
>
>                 Key: MNG-4449
>                 URL: http://jira.codehaus.org/browse/MNG-4449
>             Project: Maven 2
>          Issue Type: Bug
>          Components: Artifacts and Repositories, Dependencies
>    Affects Versions: 3.0-alpha-3
>            Reporter: Simon Tiffert
>            Assignee: Benjamin Bentmann
>
> I tried Maven 3.0 with our Maven 2 project.
> There were duplicated dependencies in our dependencyManagement section. After fixing
this I tried building again and was faced with the problem in some of our sub projects (but
the only dependency version definition is in the parent pom). 
> I figured out, that the parent-pom in the local repository is used which is still the
old one. After deleting the folder in the local repository it was fetched again from our Archiva
server. 
> I could fix the problem when I copy the content of the local pom into the downloaded
pom in the local repository.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message