maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoffrey Wiseman (JIRA)" <>
Subject [jira] Created: (MGPG-18) NPE in GpgSigner
Date Tue, 03 Nov 2009 19:04:56 GMT
NPE in GpgSigner

                 Key: MGPG-18
             Project: Maven 2.x GPG Plugin
          Issue Type: Bug
    Affects Versions: 1.0-alpha-4
            Reporter: Geoffrey Wiseman
            Priority: Minor

If I run "mvn package gpg:sign", this works.  If I run "mvn gpg:sign", I get the following
stack trace:

	at org.apache.maven.plugin.gpg.GpgSigner.generateSignatureForArtifact(
	at org.apache.maven.plugin.gpg.GpgSignAttachedMojo.execute(
	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(
	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(

After running this through a debugger, I can see that this is because the 'file' object (project.getArtifact().getFile())
is null, which seems to be the case any time the artifact wasn't generated in this invocation
of Maven.  At the very least, this should result in a good error message, although it would
be nice if "gpg:sign" would work on an artifact that was previously-generated.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message