maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "BJ Allmon (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MASSEMBLY-453) Maven assembly plugin doesn't throws error when dependency version contains the brackets for tight tolerance
Date Wed, 02 Dec 2009 19:32:55 GMT
Maven assembly plugin doesn't throws error when dependency version contains the brackets for
tight tolerance
------------------------------------------------------------------------------------------------------------

                 Key: MASSEMBLY-453
                 URL: http://jira.codehaus.org/browse/MASSEMBLY-453
             Project: Maven 2.x Assembly Plugin
          Issue Type: Bug
    Affects Versions: 2.2-beta-1
         Environment: Any
            Reporter: BJ Allmon
            Priority: Minor


Current behavior:
A module that executes an assembly will fail with a build error indicating that the dependency
artifact version is null for any dependency that includes brackets.

The brackets are used indirectly through a property. For example: 
<version>${myApplication.currentVersion}</version> = <version>[1.0-SNAPSHOT]</version>

The work around(s): 
1. Manage static dependency versions in the POM files that include the assembly
2. Maintain two different properties. One for build dependencies with brackets and one for
assemblies without brackets.

FIX:
The assembly plugin should simply ignore possible dependency ranges and other things that
are used. Larger projects use properties for version when there are several modules to manage.

Plugin details: http://maven.apache.org/plugins/maven-assembly-plugin/

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message