maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Wirth (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MNG-4478) deploy plugin altDeploymentRepository does not use authorization credentials
Date Wed, 02 Dec 2009 16:16:55 GMT
deploy plugin altDeploymentRepository does not use authorization credentials
----------------------------------------------------------------------------

                 Key: MNG-4478
                 URL: http://jira.codehaus.org/browse/MNG-4478
             Project: Maven 2
          Issue Type: Bug
          Components: Deployment
    Affects Versions: 3.0-alpha-5, 3.0-alpha-4
            Reporter: Marc Wirth
         Attachments: maven-deploy-plugin-1.patch

When using the altDeploymentRepository of the deploy plugin (2.4 or 2.5-SNAPSHOT) the (Default)ArtifactRepository
will have no Authorization object set, thus deployment will fail if the repository requires
authorization.

My expectation was that authorization credentials are picked up if a <server> with matching
ID is configured in the settings.xml.

The attached patch fixes this the hard way in the deploy plugin, but the change requires building
the deploy plugin against maven 3.0-alpha. I think this should rather be fixed in Maven itself
if possible, but I don't know how to do that.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message