maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MEV-644) xerces:xercesImpl is missing verisons greater than 2.8.0 in metadata
Date Wed, 03 Feb 2010 23:37:55 GMT

     [ http://jira.codehaus.org/browse/MEV-644?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Carlos Sanchez closed MEV-644.
------------------------------

    Resolution: Fixed
      Assignee: Carlos Sanchez

> xerces:xercesImpl is missing verisons greater than 2.8.0 in metadata
> --------------------------------------------------------------------
>
>                 Key: MEV-644
>                 URL: http://jira.codehaus.org/browse/MEV-644
>             Project: Maven Evangelism
>          Issue Type: Bug
>          Components: Invalid Metadata
>            Reporter: Karla Jacobsen
>            Assignee: Carlos Sanchez
>
> The maven-metadata.xml for xerces:xercesImpl is missing versions 2.8.1, 2.9.0, and 2.9.1.
> As a side note, this was a very difficult issue to decode for a newbie. It would be very
helpful to have more documentation, or better error messages to indicate that bad metadata
could be the cause of resolve problems. I was seeing the problem when trying to use a range
of versions, or when specifying a constrained range (e.g. [2.8.1,) or [2.8.1]). My build succeeded
when I just used 2.8.1, so it took me quite a while to figure out why. 
> In case it is helpful...I was running a build using the Ant Maven task 'dependencies'
and the following pom.xml:
> <project>
>   <modelVersion>4.0.0</modelVersion>
>   <groupId>com.mycompany</groupId>
>   <artifactId>example</artifactId>
>   <version>1.1.1</version>
>   <dependencies>
>     <dependency>
>       <groupId>xerces</groupId>
>       <artifactId>xercesImpl</artifactId>
>       <version>[2.8.1,2.9.1]</version>
>     </dependency>
>     <dependency>
>       <groupId>xalan</groupId>
>       <artifactId>xalan</artifactId>
>       <version>[2.7.0,2.7.1]</version>
>     </dependency>
>   </dependencies>  
> </project>
> Here is the relevant Ant output (when running in verbose mode):
> [artifact:pom] Loading Maven settings file: C:\bin\apache-maven-2.0.9\conf\settings.xml
> [available] Found: .pom.xml
> -resolve-compile-dependencies:
> [artifact:dependencies] Loading Maven settings file: C:\bin\apache-maven-2.0.9\conf\settings.xml
> [artifact:dependencies] Maven Ant Tasks version: 2.0.10
> [artifact:dependencies] Using local repository: C:\Documents and Settings\kjacobse\.m2\repository
> [artifact:dependencies] Resolving dependencies...
> [artifact:dependencies] Using remote repositories:
>   - id=enterprise.mvn.repository, url=file:///V:/depot/maven, releases=enabled, snapshots=enabled
>   - id=central, url=http://localhost:8081/nexus/content/repositories/MavenProxy/, releases=enabled,
snapshots=disabled
> com.mycompany:example:jar:1.1.1 (selected)
> [artifact:dependencies] [INFO] artifact xerces:xercesImpl: checking for updates from
enterprise.mvn.repository
> [artifact:dependencies] [INFO] artifact xerces:xercesImpl: checking for updates from
central
> [artifact:dependencies] An error has occurred while processing the Maven artifact tasks.
> [artifact:dependencies]  Diagnosis:
> [artifact:dependencies] 
> [artifact:dependencies] Unable to resolve artifact: Couldn't find a version in [2.0.0,
2.0.2, 2.2.1, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.6.1, 2.6.2, 2.7.1, 2.8.0] to match range [2.8.1,2.9.1]
> [artifact:dependencies]   xerces:xercesImpl:jar:null
> [artifact:dependencies] 
> [artifact:dependencies] from the specified remote repositories:
> [artifact:dependencies]   enterprise.mvn.repository (file:///V:/depot/maven),
> [artifact:dependencies]   central (http://localhost:8081/nexus/content/repositories/MavenProxy/)
> [artifact:dependencies] 
> [artifact:dependencies] Path to dependency: 
> [artifact:dependencies] 	1) com.mycompany:example:jar:1.1.1
> [artifact:dependencies] 
> [artifact:dependencies] 
> [artifact:dependencies] 
> BUILD FAILED
> C:\eclipse\eclipse-workspaces\eclipse-jee-galileo\galileo\build\super-build.xml:406:
Unable to resolve artifact: Couldn't find a version in [2.0.0, 2.0.2, 2.2.1, 2.3.0, 2.4.0,
2.5.0, 2.6.0, 2.6.1, 2.6.2, 2.7.1, 2.8.0] to match range [2.8.1,2.9.1]
>   xerces:xercesImpl:jar:null
> from the specified remote repositories:
>   enterprise.mvn.repository (file:///V:/depot/maven),
>   central (http://localhost:8081/nexus/content/repositories/MavenProxy/)
> Path to dependency: 
> 	1) com.mycompany:example:jar:1.1.1
> 	at org.apache.maven.artifact.ant.DependenciesTask.doExecute(DependenciesTask.java:175)
> 	at org.apache.maven.artifact.ant.AbstractArtifactTask.execute(AbstractArtifactTask.java:678)
> 	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
> 	at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> 	at java.lang.reflect.Method.invoke(Unknown Source)
> 	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
> 	at org.apache.tools.ant.Task.perform(Task.java:348)
> 	at org.apache.tools.ant.Target.execute(Target.java:357)
> 	at org.apache.tools.ant.Target.performTasks(Target.java:385)
> 	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
> 	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
> 	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
> 	at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
> 	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
> 	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
> 	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)
> Caused by: org.apache.maven.artifact.versioning.OverConstrainedVersionException: Couldn't
find a version in [2.0.0, 2.0.2, 2.2.1, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.6.1, 2.6.2, 2.7.1, 2.8.0]
to match range [2.8.1,2.9.1]
>   xerces:xercesImpl:jar:null
> from the specified remote repositories:
>   enterprise.mvn.repository (file:///V:/depot/maven),
>   central (http://localhost:8081/nexus/content/repositories/MavenProxy/)
> Path to dependency: 
> 	1) com.mycompany:example:jar:1.1.1
> 	at org.apache.maven.artifact.resolver.DefaultArtifactCollector.recurse(DefaultArtifactCollector.java:375)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactCollector.collect(DefaultArtifactCollector.java:74)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:300)
> 	at org.apache.maven.artifact.ant.DependenciesTask.doExecute(DependenciesTask.java:170)
> 	... 16 more
> --- Nested Exception ---
> org.apache.maven.artifact.versioning.OverConstrainedVersionException: Couldn't find a
version in [2.0.0, 2.0.2, 2.2.1, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.6.1, 2.6.2, 2.7.1, 2.8.0] to
match range [2.8.1,2.9.1]
>   xerces:xercesImpl:jar:null
> from the specified remote repositories:
>   enterprise.mvn.repository (file:///V:/depot/maven),
>   central (http://localhost:8081/nexus/content/repositories/MavenProxy/)
> Path to dependency: 
> 	1) com.mycompany:example:jar:1.1.1
> 	at org.apache.maven.artifact.resolver.DefaultArtifactCollector.recurse(DefaultArtifactCollector.java:375)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactCollector.collect(DefaultArtifactCollector.java:74)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:300)
> 	at org.apache.maven.artifact.ant.DependenciesTask.doExecute(DependenciesTask.java:170)
> 	at org.apache.maven.artifact.ant.AbstractArtifactTask.execute(AbstractArtifactTask.java:678)
> 	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
> 	at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> 	at java.lang.reflect.Method.invoke(Unknown Source)
> 	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
> 	at org.apache.tools.ant.Task.perform(Task.java:348)
> 	at org.apache.tools.ant.Target.execute(Target.java:357)
> 	at org.apache.tools.ant.Target.performTasks(Target.java:385)
> 	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
> 	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
> 	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
> 	at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
> 	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
> 	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
> 	at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message