maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven MountJoy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-456) [regression] Site navigation not generated
Date Wed, 03 Mar 2010 15:57:55 GMT

    [ http://jira.codehaus.org/browse/MSITE-456?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=212305#action_212305
] 

Steven MountJoy commented on MSITE-456:
---------------------------------------

Confirming Paul's bug. My inherited set of <reporting> plugins are generating their
separate reports as defined but are not being linked in the div "navcolumn" of the generated
index.html. I, too, have reverted to 2.0.1 for workaround.

> [regression] Site navigation not generated
> ------------------------------------------
>
>                 Key: MSITE-456
>                 URL: http://jira.codehaus.org/browse/MSITE-456
>             Project: Maven 2.x Site Plugin
>          Issue Type: Bug
>    Affects Versions: 2.1
>         Environment: Apache Maven 2.2.1 (r801777; 2009-08-06 14:16:01-0500)
> Java version: 1.6.0_16
> Java home: d:\jdk1.6.0_16\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"
>            Reporter: Paul Benedict
>            Priority: Critical
>             Fix For: 2.1.1
>
>         Attachments: MSITE-456.zip
>
>
> My corporate POM locks down the maven-site-plugin to version 2.1. The site of the corporate
POM generates just fine. However, when a child project inherits from it, that project's site
contains no left-hand navigation. Reverting to 2.0.1 is my workaround.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message