maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "fabrizio giustina (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MECLIPSE-585) [regression] plugin fails to create Eclipse projects in 2.7
Date Tue, 06 Apr 2010 20:56:23 GMT

     [ http://jira.codehaus.org/browse/MECLIPSE-585?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

fabrizio giustina closed MECLIPSE-585.
--------------------------------------

    Resolution: Duplicate

fixed in 2.9, same as MECLIPSE-621

> [regression] plugin fails to create Eclipse projects in 2.7
> -----------------------------------------------------------
>
>                 Key: MECLIPSE-585
>                 URL: http://jira.codehaus.org/browse/MECLIPSE-585
>             Project: Maven 2.x Eclipse Plugin
>          Issue Type: Bug
>          Components: Core : .project
>    Affects Versions: 2.7
>            Reporter: Joerg Schaible
>            Assignee: fabrizio giustina
>            Priority: Blocker
>             Fix For: 2.9
>
>
> Since version 2.7 of the plugin it is no longer possible to create Eclipse projects for
Apache commons-vfs.
> Steps to reproduce
> # Check out https://svn.apache.org/repos/asf/commons/proper/vfs/trunk
> # Call "mvn eclipse:clean eclipse:eclipse"
> Maven stops with an error reported from the plugin. With version 2.6 it is possible to
create the projects, call
>  mvn org.apache.maven.plugins:maven-eclipse-plugin:2.6:clean org.apache.maven.plugins:maven-eclipse-plugin:2.6:eclipse
> The output for version 2.7 is:
> {noformat}
> ...
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Commons VFS Core
> [INFO]    task-segment: [eclipse:eclipse]
> [INFO] ------------------------------------------------------------------------
> [INFO] Preparing eclipse:eclipse
> [INFO] [antrun:run {execution: javadoc.resources}]
> [INFO] Executing tasks
> [INFO] Executed tasks
> [INFO] [eclipse:eclipse {execution: default-cli}]
> [INFO] Using Eclipse Workspace: null
> [INFO] Adding default classpath container: org.eclipse.jdt.launching.JRE_CONTAINER
> [INFO] Resource directory's path matches an existing source directory. Resources will
be merged with the source directory src/main/java
> [INFO] Resource directory's path matches an existing source directory. Resources will
be merged with the source directory /home/jos/src/Apache/Commons/Proper/vfs
> [INFO] Resource directory's path matches an existing source directory. Resources will
be merged with the source directory /home/jos/src/Apache/Commons/Proper/vfs
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Request to merge when 'output' is not identical. Original=resource /home/jos/src/Apache/Commons/Proper/vfs:
output=target/test-classes/META-INF, include=[NOTICE.txt], exclude=[**/*.java], test=true,
filtering=false, merging with=resource /home/jos/src/Apache/Commons/Proper/vfs: output=target/test-classes,
include=[LICENSE.txt], exclude=[**/*.java], test=true, filtering=false
> [INFO] ------------------------------------------------------------------------
> ...
> {noformat}
> While the error is technically correct and the Eclipse project produced by version 2.6
is not valid, I have still the possibility to fix the Eclipse project manually. However, since
the plugin with 2.7 will not create anything, it is really worse and I am completely left
alone. Therefore, it is fine to print an explicit waring on the screen, but you should nevertheless
create the project and continue.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message