maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anders Hammar (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MENFORCER-96) 'requirePluginVersions' recognizises some released maven-plugins as SNAPSHOTS
Date Thu, 06 May 2010 06:54:12 GMT

    [ http://jira.codehaus.org/browse/MENFORCER-96?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=220142#action_220142
] 

Anders Hammar commented on MENFORCER-96:
----------------------------------------

Are the versions of these plugins really pinned down? I saw some other jira where it explains
that version has to be set in the project (or its parent); versions defined in the Super POM
are ignored by this rule (by design).


> 'requirePluginVersions' recognizises some released maven-plugins as SNAPSHOTS
> -----------------------------------------------------------------------------
>
>                 Key: MENFORCER-96
>                 URL: http://jira.codehaus.org/browse/MENFORCER-96
>             Project: Maven 2.x Enforcer Plugin
>          Issue Type: Bug
>          Components: Standard Rules
>    Affects Versions: 1.0-beta-1
>            Reporter: Lars Corneliussen
>
> Have a look at this log. 2.4 can't be a snapshot, can it?
> {noformat} 
> [INFO] [enforcer:enforce {execution: default-cli}]
> [WARNING] Rule 2: org.apache.maven.plugins.enforcer.RequirePluginVersions failed with
message:
> Some plugins are missing valid versions:(SNAPSHOT are not allowed )
> org.apache.maven.plugins:maven-clean-plugin.    The version currently in use is 2.4
> org.apache.maven.plugins:maven-deploy-plugin.   The version currently in use is 2.5
> org.apache.maven.plugins:maven-install-plugin.  The version currently in use is 2.3
> org.apache.maven.plugins:maven-site-plugin.     The version currently in use is 2.1
> {noformat} 
> {code:xml}
> <plugin>
>   <groupId>org.apache.maven.plugins</groupId>
>   <artifactId>maven-enforcer-plugin</artifactId>
>   <version>1.0-beta-1</version>
>   <configuration>
>     <rules>
>       <requireReleaseVersion />
>       <requireReleaseDeps>
>         <message>All dependencies must be released!</message>
>         <failWhenParentIsSnapshot>true</failWhenParentIsSnapshot>
>       </requireReleaseDeps>
>       <requirePluginVersions>
>         <banRelease>false</banRelease>
>         <banLatest>false</banLatest>
>         <banSnapshots>true</banSnapshots>
>         <banTimestamps>false</banTimestamps>
>         <!-- unCheckedPlugins>
>           <unCheckedPlugin>org.apache.maven.plugins:maven-clean-plugin</unCheckedPlugin>
>           <unCheckedPlugin>org.apache.maven.plugins:maven-deploy-plugin</unCheckedPlugin>
>           <unCheckedPlugin>org.apache.maven.plugins:maven-install-plugin</unCheckedPlugin>
>           <unCheckedPlugin>org.apache.maven.plugins:maven-site-plugin</unCheckedPlugin>
>         </unCheckedPlugins -->
>       </requirePluginVersions>
>     </rules>
>     <fail>true</fail>
>   </configuration>
> </plugin>
> {code}
> When I list the plugins as unChecked, it passes.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message