maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Hughes (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-477) <menu ref="modules"/> href's drop the leading character in the href
Date Mon, 10 May 2010 00:15:14 GMT

    [ http://jira.codehaus.org/browse/MSITE-477?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=220612#action_220612
] 

Andrew Hughes commented on MSITE-477:
-------------------------------------

{quote}
I'm confused. Is this a multi module issue or not?
{quote}
Yes. Very very very odd that it is doing this. There is nothing special about the parent or
module pom's. I am not using a site skin and I have not messesd with any of the velocity templates.
Perhaps rather than submitting a few pom's that will no doubt work on your configuration -
perhaps I should try and debug this from mine? Problem is I don't know where to start looking
to see where in the plugin the module href's are generated.

> <menu ref="modules"/> href's drop the leading character in the href
> -------------------------------------------------------------------
>
>                 Key: MSITE-477
>                 URL: http://jira.codehaus.org/browse/MSITE-477
>             Project: Maven 2.x Site Plugin
>          Issue Type: Bug
>          Components: multi module
>    Affects Versions: 2.0.1, 2.1
>            Reporter: Andrew Hughes
>
> parent pom.xml:
> {noformat}
> <module>module-a</modules>
> {noformat}
> parent site.xml:
> {noformat}
> <menu ref="modules"/>
> {noformat}
> The generated html links to "module-a" look like this....
> {noformat}
> <a href="odule-a/index.html" title="module-a">module-a</a>
> {noformat}
> Note, the href is missing the leading character "m", it should be..
> {noformat}
> <a href="module-a/index.html" title="module-a">module-a</a>
> {noformat}
> I tried to run this wil 2.0.1 and 2.1 - but got the same result with both. Hopfully this
is a mis-configuration on my part, but if it is then perhaps it can be tested by the plugin
and can fail the build.
> Thanks for reading :)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message