maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Bourg (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (WAGON-237) keyboard-interactive method is used even when password is supplied
Date Thu, 24 Jun 2010 13:24:12 GMT

    [ http://jira.codehaus.org/browse/WAGON-237?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=226225#action_226225
] 

Emmanuel Bourg commented on WAGON-237:
--------------------------------------

I'm under the impression this issue still exists. I'm trying to mvn deploy to people.apache.org
with the username and password specified in settings.xml. I'm still getting the "Keyboard
interactive required, supplied password is ignored" prompt. I tested with wagon-ssh 1.0-beta-5
and 1.0-beta-6.

> keyboard-interactive method is used even when password is supplied
> ------------------------------------------------------------------
>
>                 Key: WAGON-237
>                 URL: http://jira.codehaus.org/browse/WAGON-237
>             Project: Maven Wagon
>          Issue Type: Bug
>          Components: wagon-ssh
>    Affects Versions: 1.0-beta-4
>         Environment: Maven version: 2.0.10-RC8
> Java version: 1.5.0_13
> Default locale: en_US, platform encoding: ISO8859-1
> OS name: "sunos" version: "5.10" arch: "sparc" family: "unix"
>            Reporter: David J. M. Karlsen
>            Assignee: Brett Porter
>             Fix For: 1.0-beta-5
>
>
> Starting from 2.0.10-RC8 deploy (with ssh and password) started to fail - I'm getting:
> [DEBUG] Connecting to repository: 'repo.sandsli.dnb.no' with url: 'scp://repo.sandsli.dnb.no/dnb/data/proximity/inhouse.snapshot/storage'.
> Keyboard interactive required, supplied password is ignored
> event though the pw is in settings.xml:
> With help from Brett this was added:
> <build>
>     <extensions>
>       <extension>
>         <groupId>org.apache.maven.wagon</groupId>
>         <artifactId>wagon-ssh</artifactId>
>         <version>1.0-beta-2</version>
>       </extension>
>     </extensions>
> which resolved the case.
> Fragment from settings.xml:
>  <servers>
>     <server>
>       <username>MyUser</username>
>       <password>MySecret</password>
>       <filePermissions>777</filePermissions>
>       <directoryPermissions>777</directoryPermissions>
>       <id>repo.sandsli.dnb.no</id>
>     </server>
> Fragment from pom.xml:
>  <distributionManagement>
>     <repository>
>       <id>repo.sandsli.dnb.no</id>
>       <name>DnBNOR Felles Repository</name>
>       <url>scp://repo.sandsli.dnb.no/dnb/data/proximity/inhouse/storage</url>
>     </repository>
>     <snapshotRepository>
>       <id>repo.sandsli.dnb.no</id>
>       <name>DnBNOR Felles Snapshot Repository</name>
>       <url>scp://repo.sandsli.dnb.no/dnb/data/proximity/inhouse.snapshot/storage</url>
>     </snapshotRepository>
>     <site>
>       <id>repo.sandsli.dnb.no</id>
>       <url>scp://repo.sandsli.dnb.no/dnb/prosess/prosjektdok/no.dnbnor.websphere-1.3-SNAPSHOT/websphere-testenvironment</url>
>     </site>
>   </distributionManagement>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message