maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MPIR-194) [WARNING] Deprecated API called
Date Fri, 02 Jul 2010 15:51:33 GMT

    [ http://jira.codehaus.org/browse/MPIR-194?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=227042#action_227042
] 

Herve Boutemy commented on MPIR-194:
------------------------------------

I tracked the issue:
1. the message is written by maven-reporting-impl and is not very informative: when MSHARED-159
is fixed, updating the dependency will avoid the message
2. the real bug is in maven-site-plugin: see MSITE-490

> [WARNING] Deprecated API called
> -------------------------------
>
>                 Key: MPIR-194
>                 URL: http://jira.codehaus.org/browse/MPIR-194
>             Project: Maven 2.x Project Info Reports Plugin
>          Issue Type: Improvement
>    Affects Versions: 2.2
>            Reporter: Lukas Theussl
>            Priority: Minor
>
> Version 2.2 spits out a warning for each generated page:
> {noformat}
> [WARNING] Deprecated API called - not org.apache.maven.doxia.sink.Sink instance and no
SinkFactory available. Please update this plugin.
> {noformat}
> The warning can be ignored AFAICT but it is annoying and confusing for users.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message