maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anders Hammar (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MNG-4760) Way to activate profile based on Maven version
Date Wed, 11 Aug 2010 08:38:32 GMT
Way to activate profile based on Maven version
----------------------------------------------

                 Key: MNG-4760
                 URL: http://jira.codehaus.org/browse/MNG-4760
             Project: Maven 2 & 3
          Issue Type: New Feature
          Components: Profiles
    Affects Versions: 3.0-beta-2
         Environment: n/a
            Reporter: Anders Hammar


A profile activation that checks the version of Maven being used would be good. For example,
the site plugin requires a different version when Maven 3 is used. Currently, this is done
through a profile that activates based on teh fact that the basedir expression is only recognized
by Maven 3.x, which is IMO a not-so-pretty solution. (See https://cwiki.apache.org/confluence/display/MAVEN/Maven+3.x+and+site+plugin#Maven3.xandsiteplugin-Usingmavensiteplugin2.xwithMaven2.xandmavensiteplugin3.xwithMaven3.x)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message