maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Herve Boutemy (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (ARCHETYPE-300) breaking change in 2.0-alpha-5: no longer support remoteRepository
Date Thu, 12 Aug 2010 20:36:32 GMT

     [ http://jira.codehaus.org/browse/ARCHETYPE-300?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Herve Boutemy updated ARCHETYPE-300:
------------------------------------

    Affects Version/s: 2.0-alpha-1
        Fix Version/s:     (was: 2.0-alpha-6)

> breaking change in 2.0-alpha-5: no longer support remoteRepository
> ------------------------------------------------------------------
>
>                 Key: ARCHETYPE-300
>                 URL: http://jira.codehaus.org/browse/ARCHETYPE-300
>             Project: Maven Archetype
>          Issue Type: Bug
>          Components: Generator
>    Affects Versions: 2.0-alpha-1, 2.0-alpha-5
>            Reporter: David Bernard
>            Priority: Blocker
>
> Since 2.0-alpha-5 property "remoteRepositories" is replace by "archetypeRepository".
I agree it's a better name, but it introduce BREAKING change for the command like
> {code}
> mvn archetype:generate -U \
> -DarchetypeGroupId=net.liftweb \
> -DarchetypeArtifactId=lift-archetype-basic \
> -DarchetypeVersion=1.0 \
> -DremoteRepositories=http://scala-tools.org/repo-releases \
> -DgroupId=xxx \
> -DartifactId=xxx \
> -Dversion=xxx
> {code}
> And this kind of command is provide in lot of framework documentation (lift, wicket,...).
Break it raise trouble for new user (and other).
> Please provide a update (to be backward compatible) ASAP.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message