maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MNG-4748) svn checkout - special characters in file name are not encoding properly
Date Thu, 05 Aug 2010 09:15:32 GMT

     [ http://jira.codehaus.org/browse/MNG-4748?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benjamin Bentmann closed MNG-4748.
----------------------------------

    Resolution: Not A Bug

bq. <taskdef name="svn" classname="org.tigris.subversion.svnant.SvnTask" classpathref="project.classpath"/>
This is the component doing the checkout, and this is not Maven. It runs in the context of
a Maven build but that doesn't make Maven responsible for the misbehavior of this component,
just like a misbehaving Java application is not a bug of the JVM. For getting qualified help,
it's important to address the community maintaining the affected component (SVN Ant Task).

You can freely continue your discussion here but the Maven core cannot help you solve your
issue with third-party tools.

> svn checkout - special characters in file name are not encoding properly
> ------------------------------------------------------------------------
>
>                 Key: MNG-4748
>                 URL: http://jira.codehaus.org/browse/MNG-4748
>             Project: Maven 2 & 3
>          Issue Type: Bug
>          Components: POM::Encoding
>    Affects Versions: 2.2.1
>         Environment: UNIX
>            Reporter: Sunny
>            Assignee: Benjamin Bentmann
>
> Dear All,
>      I'm working on europe based project, which has so many file names are having with
special characters like control characters and cannon(hat) characters supported by windows-1252
support characters. We are using svn repository and for the application build and deployment
we are using maven tool, while deploying the .ear through using maven the special characters
which are supported by windows-1252(e.g. Š) are not converting properly. At the place of
those characters i'm getting '?', Hence, the deployment is failing at runtime.
>      I've done so many encoding techniques, but still the problem remains same. Please
help to resolve this issue ASAP!!!, due to this issue, my application has been stopped.
> I'm glad to get the solution soon.
> Regards,
> Sunny

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message