maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <>
Subject [jira] Commented: (MRELEASE-387) command line versions don't seem to work on release:branch
Date Wed, 29 Sep 2010 08:09:33 GMT


Brett Porter commented on MRELEASE-387:

Christoph - I'm looking at this as part of MRELEASE-524 that raised it also

> command line versions don't seem to work on release:branch
> ----------------------------------------------------------
>                 Key: MRELEASE-387
>                 URL:
>             Project: Maven 2.x Release Plugin
>          Issue Type: Bug
>          Components: branch
>    Affects Versions: 2.0-beta-8
>         Environment: maven 2.0.9 and 2.1.0 M1, maven release plugin 2.0-beta-8
>            Reporter: Jeff Vogelsang
>            Assignee: Olivier Lamy
>             Fix For: 2.0
>         Attachments: addSupportForVersion.patch
> I have tried all the various permutations for passing versions to the command line while
making a branch. The plugin ignores my parameters when running release:branch. It either interactively
prompts for new versions, or injects the defaults if I pass parameters in batch mode.
> Here's an example of two commands I have tried running that don't work:
> mvn release:branch -DbranchName=RB-[top-level-project-name]-1.0.4 -DautoVersionSubmodules=true
-DupdateBranchVersions=true -DupdateWorkingCopyVersions=false -DdevelopmentVersion=1.0.4-SNAPSHOT
> mvn release:branch -DbranchName=RB-[top-level-project-name]-1.0.4 -DautoVersionSubmodules=true
-DupdateBranchVersions=true -DupdateWorkingCopyVersions=false[org package].[top-level-project-name]=1.0.4-SNAPSHOT
> Both of those commands prompt me for versions and no matter what parameters I type use
the current project revision as the default. If I do batch mode with --batch or -B, the release
plugin just injects the current project revision into the branch and ignores my parameters.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message