maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Phillips (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MSITE-505) Unable to use SVN SCM wagon to upload a site
Date Mon, 20 Sep 2010 21:14:32 GMT
Unable to use SVN SCM wagon to upload a site
--------------------------------------------

                 Key: MSITE-505
                 URL: http://jira.codehaus.org/browse/MSITE-505
             Project: Maven 2.x Site Plugin
          Issue Type: Bug
          Components: site:deploy
    Affects Versions: 3.0-beta-2
         Environment: Maven 3.0-beta-3 (r990787; 2010-08-30 14:44:03+0200)
Maven site plugin 3.0-beta-3-SNAPSHOT
            Reporter: Andrew Phillips
         Attachments: mvn-X-output.txt, pom.xml

Even though the SCM project is apparently able to correctly pick up the SVN provider in the
attached POM, the site plugin is unable to deploy to a site with an 'scm:svn...' URL and warns
that 

[WARNING] No SCM providers configured.

Here the abbreviated output of two commands - see the attachment for the full output.

> mvn scm:status
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building SCM deploy:site test 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- maven-scm-plugin:1.4:status (default-cli) @ scm-deploy-test ---
[INFO] Executing: cmd.exe /X /C "svn --non-interactive status"
[INFO] Working directory: XXX
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------

> mvn site:deploy -X

[DEBUG] The site will be deployed to url 'scm:svn:https://acme.com/svn/site' with id 'scm-deploy-test-site'
[DEBUG] repository protocol scm
[DEBUG] getProxy 'protocol' : scm
[DEBUG] getProxy 'protocol' : scm no ProxyInfo found
[DEBUG] found proxyInfo null
[DEBUG] authenticationInfo with id 'scm-deploy-test-site' : null
[WARNING] No SCM providers configured.
[DEBUG]  configureWagon 
[DEBUG] configureWagon server XXX
...
[DEBUG] configureWagon server XXX
[DEBUG] connect with authenticationInfo and without proxyInfo
scm:svn:https://acme.com/svn/site - Session: Opened  
 Transfer error: org.apache.maven.scm.manager.NoSuchScmProviderException: No such provider:
'svn'.
scm:svn:https://acme.com/svn/site - Session: Disconnecting  
scm:svn:https://acme.com/svn/site - Session: Disconnected
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message