maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MRELEASE-370) release:prepare is not updating inter-modules dependencies to the next version snapshot identifier correctly (-DdryRun=true).
Date Thu, 23 Sep 2010 09:13:32 GMT

     [ http://jira.codehaus.org/browse/MRELEASE-370?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brett Porter closed MRELEASE-370.
---------------------------------

       Resolution: Fixed
    Fix Version/s: 2.1
         Assignee: Brett Porter

> release:prepare is not updating inter-modules dependencies to the next version snapshot
identifier correctly (-DdryRun=true).
> -----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MRELEASE-370
>                 URL: http://jira.codehaus.org/browse/MRELEASE-370
>             Project: Maven 2.x Release Plugin
>          Issue Type: Bug
>          Components: prepare
>    Affects Versions: 2.0-beta-7
>         Environment: maven 2.0.9 on windows
>            Reporter: David Van den Brande
>            Assignee: Brett Porter
>             Fix For: 2.1
>
>         Attachments: AbstractRewritePomsPhase.patch
>
>
> Case:
> project (version 1.0.4-SNAPSHOT)
> -	pom.xml with
> 	<modules>
> 		<module>module1</module>
>                 <module>module2</module>
> 	</modules>
> project/module1 (version 1.0.4-SNAPSHOT)
> -	pom.xml with "project" as its parent
> -	dependency on module2
> project/module2 (version 1.0.4-SNAPSHOT)
> -	pom.xml with "project" as its parent
> In the "project" folder run 
> -	mvn -DdryRun=true release:prepare -DpreparationGoals=clean
>          => release version: 1.0.4
>          => next dev version: 1.0.5-SNAPSHOT
> Result:
> * "project" pom has two correct pom versions: pom.xml.tag & pom.xml.next
> * "module" pom: 
>        - correct pom.xml.tag, meaning:
>                => correct parent/version: 1.0.4-SNAPSHOT
>                => correct module2 dependency moved from 1.0.4-SNAPSHOT to 1.0.5-SNAPSHOT
>        - pom.xml.next:
>                => correct parent/version: 1.0.5-SNAPSHOT
>                => wrong module2 dependency 1.0.4-SNAPSHOT (it should be 1.0.5-SNAPSHOT)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message