maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Youri Bonnaffé (JIRA) <j...@codehaus.org>
Subject [jira] Commented: (SCM-531) Incorrect SCM URL constructed when using parent POM that is not in the parent directory
Date Mon, 22 Nov 2010 16:44:03 GMT

    [ http://jira.codehaus.org/browse/SCM-531?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=244013#action_244013
] 

Youri Bonnaffé commented on SCM-531:
------------------------------------

I experienced the same behavior as Joao.

> Incorrect SCM URL constructed when using parent POM that is not in the parent directory
> ---------------------------------------------------------------------------------------
>
>                 Key: SCM-531
>                 URL: http://jira.codehaus.org/browse/SCM-531
>             Project: Maven SCM
>          Issue Type: Bug
>          Components: maven-scm-site
>         Environment: Apache Maven 2.2.0 (r788681; 2009-06-26 14:04:01+0100)
> Java version: 1.6.0_16
> Java home: /usr/lib/jvm/java-6-sun-1.6.0.16/jre
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "linux" version: "2.6.31-19-generic" arch: "amd64" Family: "unix"
>            Reporter: Darren Bell
>
> In our parent pom we have this:
> {noformat}
>   <properties>
>     <scm.module>master-pom</scm.module>
>   </properties>
>   <scm>
>     <connection>scm:cvs:ext:build@server:/srv/cvs/:${scm.module}</connection>
>     <developerConnection>scm:cvs:ext:build@server:/srv/cvs/:${scm.module}</developerConnection>
>     <url>http://server/fe/browse/UK-CVS-Rsync/${scm.module}</url>
>   </scm>
> {noformat}
> Our child pom (not in the same directory), has this:
> {noformat}
>   <artifactId>dd-util</artifactId>
>   <properties>
>     <scm.module>util</scm.module>
>   </properties>
> {noformat}
> Of course, the child pom is overriding the property.  Well, it sort of works.
> When building the site of the parent pom, we get:
> {noformat}
> http://server/fe/browse/UK-CVS-Rsync/master-pom
> {noformat}
> ... which is correct.  But when building the site for the child pom, we get:
> {noformat}
> http://server/fe/browse/UK-CVS-Rsync/util/dd-util
> {noformat}
> I'm quite confused as to why it whould be appending the artifactId of the child project.
 The property is getting replaced ok, but the the extra bit?  This has got to be a bug.
> I'm not releasing the project, just building the site.
> Any ideas?  If this is against the wrong project, can it be moved?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message