maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy (JIRA)" <j...@codehaus.org>
Subject [jira] Closed: (MINVOKER-114) Update plugin code to use Java 5 language features
Date Thu, 23 Dec 2010 23:15:58 GMT

     [ http://jira.codehaus.org/browse/MINVOKER-114?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olivier Lamy closed MINVOKER-114.
---------------------------------

    Resolution: Fixed

fixed [rev 1052409|http://svn.apache.org/viewvc?view=revision&revision=1052409]
Thanks !

> Update plugin code to use Java 5 language features
> --------------------------------------------------
>
>                 Key: MINVOKER-114
>                 URL: http://jira.codehaus.org/browse/MINVOKER-114
>             Project: Maven 2.x Invoker Plugin
>          Issue Type: Improvement
>            Reporter: luke w patterson
>            Assignee: Olivier Lamy
>         Attachments: invoker-java-5.patch
>
>
> (Huge patch attached.  Hopefully it can get reviewed/applied soon, before it becomes
stale.  Luckily the patch consists only of low-risk changes that shouldn't affect the logic
functionality.)
> Since the plugin now requires Java 5 anyways (MINVOKER-111), might as well update the
code to take advantage of better language features.
> * Removed all unavoidable "raw type" warnings.
> * Where possible/equivalent, converted Iterator-based loops to enhanced for loops.
>     * Removed unnecessary dependencies to Iterator.
> * Removed unnecessary casts.
> * Enabled "useJava5" parameter of modello-maven-plugin.
> These changes should make it easier to maintain the code later.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message