maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bindul Bhowmik (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MPLUGIN-176) helpmojo: Use Java 5 generics in generated help mojo
Date Mon, 06 Dec 2010 19:35:03 GMT

     [ http://jira.codehaus.org/browse/MPLUGIN-176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bindul Bhowmik updated MPLUGIN-176:
-----------------------------------

    Attachment: MPLUGIN-176-patch.diff

Attaching a patch that uses a 'useJava5' parameter to generate help mojo with Java5 generics
support.

> helpmojo: Use Java 5 generics in generated help mojo
> ----------------------------------------------------
>
>                 Key: MPLUGIN-176
>                 URL: http://jira.codehaus.org/browse/MPLUGIN-176
>             Project: Maven 2.x Plugin Tools
>          Issue Type: Improvement
>          Components: Plugin Plugin
>    Affects Versions: 2.6
>            Reporter: Bindul Bhowmik
>            Priority: Minor
>         Attachments: MPLUGIN-176-patch.diff
>
>
> The generated help mojo class generates List and ArrayList variables and parameters without
generic collections. This causes compiler warnings for projects compiled with Java 5 or higher.
It also causes warnings in IDEs.
> Possibly an optional parameter like useJava5 in Modello Maven Plugin ([http://modello.codehaus.org/modello-maven-plugin/java-mojo.html#useJava5])
could be used to control generating the help mojo with generic collections.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message