maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukas Theussl (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MSITE-479) stage-deploy re-run's all javadoc's for every module
Date Tue, 04 Jan 2011 08:00:04 GMT

     [ http://jira.codehaus.org/browse/MSITE-479?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lukas Theussl updated MSITE-479:
--------------------------------

    Component/s: site:stage(-deploy)

> stage-deploy re-run's all javadoc's for every module
> ----------------------------------------------------
>
>                 Key: MSITE-479
>                 URL: http://jira.codehaus.org/browse/MSITE-479
>             Project: Maven 2.x and 3.x Site Plugin
>          Issue Type: Bug
>          Components: site:stage(-deploy)
>    Affects Versions: 2.1
>            Reporter: Andrew Hughes
>
> When running 'mvn clean install site:site' a javadoc's report work's as expected...
> When running 'mvn clean install site:site site:stage-deploy -DstagingSiteURL=file://c:/temp/site'
there is a problem with the javadoc report. In a multi module project each time the javadoc's
report is run, it claims all other modules have not had the javadoc's run yet - and it runs
them.
> Consequently, if I have the following multi-module layout..
> {noformat}
> ./project
> ./project/module-1
> ./project/module-2
> ./project/module-3
> ./project/module-4
> ./project/module-5
> ./project/module-6
> {noformat}
> For modules 1..6 it will complain that all other modules have not had their javadoc goal
run and the javadoc plugin will run 6x6=36 times! Note that the log's below are for module-6.
> {noformat}
> [INFO] ------------------------------------------------------------------------
> [INFO] Building module-6
> [INFO] ------------------------------------------------------------------------
> ...truncated log's...
> [INFO] Generating "JavaDocs" report.
> [WARNING] Source files encoding has not been set, using platform encoding Cp1252, i.e.
build is platform dependent!
> [ERROR] Error fetching link: http://java.sun.com/javase/6/docs/api/package-list. Ignored
it.
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-1:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-2:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-3:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-4:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-5:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc' has not
be previously called for the project: 'com.acme.project:module-6:jar:0.0.1-SNAPSHOT'. Trying
to invoke it...
> {noformat}
> The concern I have is that site:site never complains about this and it's output is correct,
why would stage-deploy be manipulating the report generation?
> Hopefully this is a mis-configuration on my part :)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message