maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Gribben (JIRA)" <>
Subject [jira] Commented: (MASSEMBLY-337) dependencySet with unpack=true cannot be used to make file permissions executable
Date Wed, 23 Feb 2011 12:29:22 GMT


Paul Gribben commented on MASSEMBLY-337:

Apologies - it is in the release note for 2.2. In my case I'm trying to unpack a jar file
(not zip) and then apply permissions. Should this work ok in 2.2?

> dependencySet with unpack=true cannot be used to make file permissions executable
> ---------------------------------------------------------------------------------
>                 Key: MASSEMBLY-337
>                 URL:
>             Project: Maven 2.x Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 2.2-beta-2
>         Environment: Maven 2.0.9, Java 1.6_04, tested on both Windows XP and CentOS 4.1
>            Reporter: John Crim
>            Assignee: John Casey
>            Priority: Blocker
>             Fix For: 2.2
>         Attachments: massembly-bug.tar.gz
> The attached tar.gz contains 2 simple test projects which exhibit this bug:
> # Project scripts-assembly generates {{}}, which
contains a single file, {{}}, with permissions {{-rwxr-xr-x}}
> # Project assembly-filemode-bug depends on project scripts-assembly.  It extracts the file into its {{/bin}} directory when creating its assembly.
> {code:xml}
> <!-- Assembly descriptor for assembly-filemode-bug project -->
>   <dependencySets>
>     <dependencySet>
>       <outputFileNameMapping></outputFileNameMapping>
>       <outputDirectory>bin</outputDirectory>
>       <unpack>true</unpack>
>       <includes>
>         <include>maven-bugs:scripts-assembly:zip:scripts</include>
>       </includes>
>       <fileMode>0755</fileMode>
>     </dependencySet>
>   </dependencySets>
> {code}
> The {{fileMode}} element does not have the desired effect.  I'm not able to find a workaround
with 2.2-beta-2 that enables me to set the executable bit on the scripts. From looking at
other bugs in MASSEMBLY, I did try configuring the scripts-assembly project to output a zip
(also tried tar.gz) containing the files with the executable bit set.  This didn't change
the outcome - the files in package #2 are still not executable.
> I consider this a highest priority bug, b/c I can find no way to get around this limitation
and make script files from a dependency executable within an installable package.  If I change
to assembly plugin version 2.2-beta-1 (which admittedly has a significant list of bugs I'd
like to avoid), this works.  I've also tried using other tar.gz for the assembly output of
both projects, but it didn't affect the outcome.
> At this point I think my best path forward is to use assembly plugin version 2.2-beta-1.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message