maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Green (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MSITE-554) Maven site plugin doesn't not work for not flat modules
Date Sun, 13 Feb 2011 19:54:22 GMT
Maven site plugin doesn't not work for not flat modules
-------------------------------------------------------

                 Key: MSITE-554
                 URL: http://jira.codehaus.org/browse/MSITE-554
             Project: Maven 2.x and 3.x Site Plugin
          Issue Type: Bug
          Components: inheritance, Maven 3, multi module, site:run
    Affects Versions: 3.0-beta-3
         Environment: Red Hat Enterprise Linux Server release 5.2 (Tikanga) x86_64 x86_64
x86_64 GNU/Linux
            Reporter: Paul Green


It looks like maven-site-plugin for maven3 does NOT work properly for modules that are not
organized in flat structure.

Example:
            <modules>
                <module>moduleA</module>
                <module>moduleB</module>

                <module>moduleB/moduleC</module>
                <module>someDir/moduleD</module>
            </modules>


Two first modules (moduleA and moduleB) are working fine - all reports are generated for them.
Next two (moduleC and moduleD) are NOT working in fact. There is even no index.html page being
generated under:
  moduleB/moduleC/target/site
or 
  someDir/moduleD/target/site
directories.


I guess that reason is that for moduleC and moduleD pom.xml are resolved NOT from reactor
BUT from local maven repository.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message