maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myron (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MCHANGES-226) issueLinkTemplatePerSystem does not work
Date Mon, 07 Feb 2011 10:24:22 GMT

    [ http://jira.codehaus.org/browse/MCHANGES-226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=254854#action_254854
] 

Myron commented on MCHANGES-226:
--------------------------------

Thanks for the sample - it does not work for me.
Page looks fine, but there are no links to the issue tracker....

i'm using maven3, might this be a problem?!
{quote}
M:\dev\test>mvn -version
Apache Maven 3.0.2 (r1056850; 2011-01-09 01:58:10+0100)
Java version: 1.6.0_22, vendor: Sun Microsystems Inc.
Java home: D:\Programme\Java\jdk6\jre
Default locale: de_AT, platform encoding: Cp1252
OS name: "windows xp", version: "5.1", arch: "x86", family: "windows"
{quote}


> issueLinkTemplatePerSystem does not work
> ----------------------------------------
>
>                 Key: MCHANGES-226
>                 URL: http://jira.codehaus.org/browse/MCHANGES-226
>             Project: Maven 2.x Changes Plugin
>          Issue Type: Bug
>          Components: changes.xml
>    Affects Versions: 2.4
>            Reporter: Myron
>            Priority: Minor
>         Attachments: MCHANGES-226.zip
>
>
> Sorry, i don't get it.
> i try to add/config my own tracking system.
> {quote}
>     <issueManagement>
>         <system>testtesttest</system>
>         <url>http://somehost.com/project/dashboard</url>
>     </issueManagement>
> {quote}
> but i cant use the %URL%, i specify this absolute in the plugin section.
> {quote}
>     <configuration>
>         <issueLinkTemplatePerSystem>
>              <testtesttest>http://somehost.com/items?query=%ISSUE%</testtesttest>
>         </issueLinkTemplatePerSystem>
>     </configuration>
> {quote}
> in my changes.xml, the system is also testtesttest.
> Tried everything, but i dont get links.
> if i use 
> {quote}
> <issueLinkTemplate>http://somehost.com/items?query=%ISSUE%</issueLinkTemplate>
> {quote}
> and "default" in changes.xml i DO get links, but always with the default value (regardless
whats specified)
> {quote}[DEBUG]   (f) issueLinkTemplate = %URL%/ViewIssue.jspa?key=%ISSUE%{quote}
> if i specify f. ex. "SourceForge" in changes.xml, the links work out-of-the-box
> tried also old suggestions like MCHANGES-166 - no success.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message