maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@codehaus.org>
Subject [jira] Updated: (MSITE-503) Site validation doesn't run against xml files processed by velocity
Date Wed, 16 Mar 2011 20:17:24 GMT

     [ http://jira.codehaus.org/browse/MSITE-503?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dennis Lundberg updated MSITE-503:
----------------------------------

    Fix Version/s: 3.0-beta-4

> Site validation doesn't run against xml files processed by velocity
> -------------------------------------------------------------------
>
>                 Key: MSITE-503
>                 URL: http://jira.codehaus.org/browse/MSITE-503
>             Project: Maven 2.x and 3.x Site Plugin
>          Issue Type: Bug
>    Affects Versions: 2.1.1
>            Reporter: Mike Youngstrom
>            Assignee: Lukas Theussl
>             Fix For: 2.3, 3.0-beta-4
>
>
> If I turn on "validate" on my site plugin it correctly validates all of my *.xml files.
 However, if I preprocess that xml file with velocity (files named *.xml.vm). Then validation
doesn't appear to run on these velocity processed xdoc files.
> To reproduce rename an xdoc file to xml.vm, give it a validation error and see if the
"validate" configuration catches it.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message