maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "SirWayne (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MDEP-307) Version range doesn't work
Date Tue, 15 Mar 2011 15:26:22 GMT
Version range doesn't work
--------------------------

                 Key: MDEP-307
                 URL: http://jira.codehaus.org/browse/MDEP-307
             Project: Maven 2.x Dependency Plugin
          Issue Type: Bug
    Affects Versions: 2.2
         Environment: Win XP, Eclipse 3.6.1
            Reporter: SirWayne
            Assignee: Brian Fox
            Priority: Critical


I want to use a version range in my dependencies, but it doesn't work. If i use the fix version,
all works fine. In my repo the version is org.eclipse.emf:common:jar:2.6.0
{code:xml} 
	<dependencies>
		<dependency>
			<groupId>org.eclipse.emf</groupId>
			<artifactId>common</artifactId>
			<version>[2.5.0,4.0.0)</version>
		</dependency>
{code} 

Error
[ERROR] An error occurred during dependency resolution of the following artifact:
    org.eclipse.emf:common:null
Caused by: No versions are present in the repository for the artifact with a range [2.5.0,4.0.0)
  org.eclipse.emf:common:jar:null

from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  myrepo(http://myRepo/m2repository)

Path to dependency: 
	1) xyz:jar:1.0.0



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message