maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Benton (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MSITE-567) nullpointer during site-deploy when your settings configuration is empty
Date Wed, 16 Mar 2011 16:26:22 GMT
nullpointer during site-deploy when your settings configuration is empty
------------------------------------------------------------------------

                 Key: MSITE-567
                 URL: http://jira.codehaus.org/browse/MSITE-567
             Project: Maven 2.x and 3.x Site Plugin
          Issue Type: Bug
          Components: site:deploy
    Affects Versions: 3.0-beta-3
         Environment: Apache Maven 3.0.3 (r1075438; 2011-02-28 11:31:09-0600)
Maven home: /usr/share/maven3/apache-maven-3.0.3
Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
Java home: /usr/lib/jvm/java-6-sun-1.6.0.24/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "2.6.32-28-generic", arch: "amd64", family: "unix"
            Reporter: Jeff Benton


My site deploy failed with a null pointer exception.

[INFO] --- maven-site-plugin:3.0-beta-3:deploy (default-deploy) @ xxx ---
[DEBUG] Configuring mojo org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy from
plugin realm ClassRealm[plugin>org.apache.maven.plugins:maven-site-plugin:3.0-beta-3, parent:
sun.misc.Launcher$AppClassLoader@6d6f0472]
[DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy' with
basic configurator -->
[DEBUG]   (f) chmod = true
[DEBUG]   (f) chmodMode = g+w,a+rX
[DEBUG]   (f) chmodOptions = -Rf
[DEBUG]   (f) inputDirectory = xxx
[DEBUG]   (f) mavenSession = org.apache.maven.execution.MavenSession@76f1fad1
[DEBUG]   (f) project = MavenProject: xxx:xxx:1.7.3-SNAPSHOT @ xxx/pom.xml
[DEBUG]   (f) settings = org.apache.maven.execution.SettingsAdapter@6d1576d7
[DEBUG] -- end configuration --
[DEBUG] The site will be deployed to url 'scp://<server>/<path>' with id '<id>'
[DEBUG] repository protocol scp
[DEBUG] getProxy 'protocol' : scp
[DEBUG] getProxy 'protocol' : scp no ProxyInfo found
[DEBUG] found proxyInfo null
[DEBUG] authenticationInfo with id '<id>' : <username>
[DEBUG]  configureWagon 
[DEBUG] configureWagon server hope
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.455s
[INFO] Finished at: Wed Mar 16 11:03:25 CDT 2011
[INFO] Final Memory: 14M/198M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy
(default-deploy) on project xxx: Execution default-deploy of goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy
failed. NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy
(default-deploy) on project xxx: Execution default-deploy of goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy
failed.
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-deploy of goal
org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:deploy failed.
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
	... 19 more
Caused by: java.lang.NullPointerException
	at org.apache.maven.plugins.site.SiteDeployMojo.configureWagon(SiteDeployMojo.java:474)
	at org.apache.maven.plugins.site.SiteDeployMojo.execute(SiteDeployMojo.java:216)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
	... 20 more
[ERROR] 
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException

I resolved the problem by removing <configuration></configuration> from my settings.xml

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message