maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Ackermann (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MSITE-547) Links to child modules do not work when using flat structure
Date Fri, 11 Mar 2011 16:17:22 GMT

    [ http://jira.codehaus.org/browse/MSITE-547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=259772#action_259772
] 

Martin Ackermann commented on MSITE-547:
----------------------------------------

Checked with 3.0-beta-4-SNAPSHOT as of today and it worked for both example projects. Thank
you for fixing this.

> Links to child modules do not work when using flat structure 
> -------------------------------------------------------------
>
>                 Key: MSITE-547
>                 URL: http://jira.codehaus.org/browse/MSITE-547
>             Project: Maven 2.x and 3.x Site Plugin
>          Issue Type: Bug
>          Components: Maven 3, multi module, relative links, site:deploy
>    Affects Versions: 3.0-beta-3
>         Environment: Maven 3.0.1, Windows XP SP3
>            Reporter: Martin Ackermann
>            Assignee: Lukas Theussl
>             Fix For: 3.0-beta-4
>
>         Attachments: trial-maven-with-urls-and-sitexml.zip, trial-maven.zip
>
>
> trial-maven-child-module has trial-maven-product as parent. When they are both in the
same directory (flat structure), "mvn site-deploy" does not generate working links for the
site. See attached example project.
> If trial-maven-child-module is a sub-directory of trial-maven-product (deep structure),
"mvn site-deploy" generates working links.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message