maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rabbe Fogelholm (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MNG-5107) bootstrap-building from source fails when behind HTTP proxy
Date Fri, 27 May 2011 12:00:22 GMT
bootstrap-building from source fails when behind HTTP proxy
-----------------------------------------------------------

                 Key: MNG-5107
                 URL: http://jira.codehaus.org/browse/MNG-5107
             Project: Maven 2 & 3
          Issue Type: Bug
          Components: Bootstrap & Build
    Affects Versions: 3.0.3
         Environment: Ant 1.8.2, J2SE JDK 1.6.0_25 downloaded from Oracle, SUSE Enterprise
11 SP0, Linux x86 2.6.27 kernel
            Reporter: Rabbe Fogelholm


Bootstrap building from source does not work. The apache-maven-3.0.3-src.tar.gz contains a
README.bootstrap.txt file that explains how to do it. It does not say what to do when behind
an HTTP proxy, but by googling I gathered that a config file should be placed in $HOME/.m2/settings.xml.

I tried to do so, with the file containing (X.Y.Z of course replaced by the actual proxy hostname)

<settings>
  <proxies>
    <proxy>
      <active>true</active>
      <protocol>http</protocol>
      <host>X.Y.Z</host>
      <port>8080</port>
      <nonProxyHosts>localhost</nonProxyHosts>
    </proxy>
  </proxies>
</settings>

I also set the JAVA_HOME, ANT_HOME and PATH variables and checked that `java -version' and
`ant -version' behaved as expected.

The console output that I get is:

$ ant

Buildfile: /local/scratch/eraswiv4/mbug/maven/apache-maven-3.0.3/build.xml

clean-bootstrap:

initTaskDefs:

isMavenHomeSet:

init:
     [echo] maven.home = /local/tmp/eraswiv4/mbug/maven/apache-maven-3.0-SNAPSHOT
     [echo] maven.repo.local = /home/eraswiv4/.m2/repository

prompt-maven-home-exists:

pull:
[artifact:pom] Downloading: org/apache/maven/maven-parent/15/maven-parent-15.pom from repository
central at http://repo1.maven.org/maven2

At this point the command hangs for a long time and fails with 

[artifact:pom] Error transferring file: Connection timed out
[artifact:pom] [WARNING] Unable to get resource 'org.apache.maven:maven-parent:pom:15' from
repository central (http://repo1.maven.org/maven2): Error transferring file: Connection timed
out
[artifact:pom] An error has occurred while processing the Maven artifact tasks.
[artifact:pom]  Diagnosis:
[artifact:pom] 
[artifact:pom] Unable to initialize POM dependencies.xml: Cannot find parent: org.apache.maven:maven-parent
for project: null:maven:pom:3.0.3 for project null:maven:pom:3.0.3
[artifact:pom] Unable to download the artifact from any repository

BUILD FAILED
/local/scratch/eraswiv4/mbug/maven/apache-maven-3.0.3/build.xml:97: Unable to initialize POM
dependencies.xml: Cannot find parent: org.apache.maven:maven-parent for project: null:maven:pom:3.0.3
for project null:maven:pom:3.0.3

Total time: 3 minutes 13 seconds



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message