maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf Eichinger (JIRA)" <j...@codehaus.org>
Subject [jira] (MENFORCER-98) requirePluginVersions rule is not compatible with maven 3.0-beta-1
Date Wed, 21 Mar 2012 15:28:03 GMT

    [ https://jira.codehaus.org/browse/MENFORCER-98?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=294778#comment-294778
] 

Ralf Eichinger commented on MENFORCER-98:
-----------------------------------------

This issue is still valid since I've tried with maven 3.0.4 and enforcer-plugin 1.0.1.
Still it is not possible to use the <requirePluginVersions> section, so also the documentation
at http://maven.apache.org/enforcer/enforcer-rules/requirePluginVersions.html seems to be
simply wrong.
                
> requirePluginVersions rule is not compatible with maven 3.0-beta-1
> ------------------------------------------------------------------
>
>                 Key: MENFORCER-98
>                 URL: https://jira.codehaus.org/browse/MENFORCER-98
>             Project: Maven 2.x Enforcer Plugin
>          Issue Type: Bug
>          Components: Standard Rules
>    Affects Versions: 1.0-beta-1
>         Environment: Windows XP
> Sun JDK 1.6.0_18
> Maven 3.0-beta-1
>            Reporter: Anders Hammar
>         Attachments: MENFORCER-98.patch
>
>
> When using the requirePluginVersions rule, I get a message saying "This rule is not compatible
with the current version of Maven. The rule is not able to perform any checks."

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message